Jump to content
Corsair Community

Unable to update firmware: No device detected


Ishigami
 Share

Recommended Posts

Okay this is driving me crazy, again.

It already hunted me with the old CUE. But I thought I give it another spin with 2.5.66.

 

To no avail.

 

The problem: When I try to update the firmware: I press on "update" and then the keyboard vanishes from CUE and the messages "No device detected" appears and the update fails at 0% right away.

 

Mind you the software is detecting the keyboard just fine when I either reset it by reconnecting the USB connectors or change the BIOS switch position.

 

But dare I press “update”, it is gone...

 

It’s usually connected via USB 2.0.

Seems to make no difference with USB 3.0. Though I only have Asmedia realized USB 3.0 (Asus Rampage IV Black).

Anyway the same result: Keyboard works > Update > Keyboard gone > Update fail.

 

I tried:

Switching USB 2.0 connectors -> No result

Switching to USB 3.0 -> No result

Switching off power saving for USB devices -> No result

This: http://forum.corsair.com/v3/showthread.php?t=154018 -> No result

 

Why is the keyboard working “fine” (except a few keys with wrong colours), is detected and once I hit “update” it goes into hiding?

Not to mention I’m currently writing on it… while it is not detected by CUE…

Link to comment
Share on other sites

Problem got resolved by support.

 

Honestly... Corsair should provide direct download of firmware versions and give instructions of the manual flashing procedure alongside it.

 

It’s so easy… could save some time on support employees.

Link to comment
Share on other sites

 Share

×
×
  • Create New...