Jump to content
Corsair Community

Corsair Void RGB usb headset not being detected on laptop


Hax1512
 Share

Recommended Posts

Hi all,

 

My brother recently purchased a corsair void rgb headset. It arrived late yesterday so I didnt have time to help him set it up. I got up this morning and started to help him with his headset.

 

First I installed CUE and then plugged his headset into his computer. This didnt do anything because it wasnt detected.

 

This is where I saw that I had a similar problem with a different USB headset with his laptop.

 

 

About an hour down the road this is what I have tried.

 

- removing the device from device manager

 

- Windows automated support (to install drivers(failed)) There were "no drivers to install"

 

- Going into device manager and disabling usb power saving settings. (shut off usb port to save power)

 

- Checked asus' webpage to find usb drivers but i couldnt find any for his comp

 

- Uninstall of CUE and uninstall of device from computer and restarted

 

- I tried plugging his headset into my laptop to see if it was a problem with the connection and it worked completely fine on my laptop.

 

 

His laptop model is the: X550dp-ds101

 

 

I have not tried going into the bios yet but I was considering doing that soon.

Link to comment
Share on other sites

What operating system is the laptop running?

What does Windows say for the headset? Is it working correctly or error due to missing drivers?

 

You can also try manually installing the drivers in Device Manger by directing it to the install folder/driver

 

 

Hi,

 

The laptop is running windows 10 but it isnt running the latest patch (Due to its numerous problems)

 

The headset doesnt even light up when i plug it in. It says that it doesnt work due to drivers on his pc though.

 

I dont know where the drivers are for the headset. A link to where to download would be much appreciated.

Link to comment
Share on other sites

Just a quick update

 

I have found it isnt a problem with the headset. Its a problem with the usb ports.

 

 

Earlier today I did a massive update that had a whole bunch of windows updates in it.

 

I also installed more recent drivers on my brother's computer.

 

I have been in the bios and changed legacy USB to auto.

 

 

If someone had a way or a method to fix the usb problem I would be very thankful

Link to comment
Share on other sites

 Share

×
×
  • Create New...