Jump to content
Corsair Community

M65 Sniper & Middle Mouse Buttons / VOID Audio Drop


Andarne

Recommended Posts

Hey guys! First timer here on the Corsair Forums! Hoping to get some answers.

 

First of all, I've already started tickets through the Force RMA site; but I've left them open for quite a while now due to other things taking up time.

 

I bought a Corsair VOID (Wired) and a Corsair M65 (non RGB) through Amazon.co.uk some time ago.

 

Initially, all was good. The VOID was comfortable, and still is, and produced lovely sound. The M65 performed well and my hand had never been as comfortable using a mouse before.

 

Some time ago, I started to notice that my VOID was cutting out the audio to either the left, right or both ear cups whenever I used the volume slider on the left ear. At first it wasn't too bad, but now if I even bump the headset slightly I lose most sound and have to fiddle with the slider to get it back. No problems with the microphone, however.

 

My M65 also started acting up. First, the middle-mouse button would no longer register being pressed down. It would initialise the click, but I could not hold it. Then, eventually, it would sometimes ignore clicks too.

 

I swapped the Middle mouse feature onto the Sniper Button (obviously losing that wonderful Sniper Mode feature in the process) but today the Sniper Button depressed and no longer clicks from where my thumb is comfortable.

 

I've since reset the keys back to default and am trying to get used to it. However, I can hear something rattling inside the mouse now...

 

Any advice will be appreciated.

 

Thank you.

Link to comment
Share on other sites

  • Corsair Employees

Since you have the USB Void headset, it may be the wiring or the connection that is loose. You may need to RMA this unit if it drops even with the slightest movement.

 

Same goes for the mouse. Something must have broken off, most likely for the scroll wheel which is causing it not to register. Time for a RMA

Link to comment
Share on other sites

Since you have the USB Void headset, it may be the wiring or the connection that is loose. You may need to RMA this unit if it drops even with the slightest movement.

 

Same goes for the mouse. Something must have broken off, most likely for the scroll wheel which is causing it not to register. Time for a RMA

 

I've submitted RMA requests already, and both have been approved.

 

Do I have to send them in individual boxes, or can I send them both in the same package with their RMA labels attached?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...