Jump to content
Corsair Community

RGB Wireless doesn´t turn on and undetected


Berakestor

Recommended Posts

Heyo.

 

I just got my Corsair Wireless RGB Headset and I already ****ed it up.

 

What happend:

1. Charged Headset. (not on pc)

2. Plugged in the USB Dongle.

3. Turned on the Headset.

4. Worked, Heard music and stuff.

5. Installed CUE.

5. Got message to update driver and to connect Headset with USB cable.

6. Update started (Was still at 0%)

7. Program crashed, Unplugged Headset (stupid)

 

So now my Headset won´t do anything. I can´t turn it on or off (I dont even know if its on or off). I can´t put it into Pairing mode. It is undetected when I plug it in to the computer. Device Manager and Devices and Printers don´t change (So it doesn´t seem to be in Bootlock mode.)

 

I tried different USB Cables and Slots. I reinstalled CUE. Tried the other version of CUE too. I tried different fixes, for example forcing the update from server, but since the headset isn´t even recognised while connected to the computer this won´t work.

 

For now Iam gonna let it stay like it is. Maybe it´s in some kind of broken Bootlock.

 

EDIT:

I decided to send them back and I requested a new one.

 

EDIT 2:

My new one works perfectly fine.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...