Jump to content
Corsair Community

G-Keys don't work at all


GTXMike

Recommended Posts

Hello. I have this issue for a while now and I didn't find the solution for this and don't know what is causing this. When I first bought my k95 everything worked fine and now g-keys wont work at all. I have the latest software reinstalled, firmware updated and windows 10 pro up to date. G-keys wont work at all, it doesn't matter what i will assign to them they simply do nothing. Anybody had similar problems?
Link to comment
Share on other sites

Things i done so far to try to fix it are:

 

1. reinstalled corsair software several times and made sure any files are deleted after uninstall

2. made sure software is up to date

3. made sure firmware is up to date

4. tried connecting the keyboard to USB 2.0

5. tried connecting the keyboard to USB 3.0 with one and two cables

6. created several new profiles and saved them to the keyboard memory

7. tried creating the new key bind / macro within the software

8. tried to recording a simple text macro directly using MR button, the recorded macro is shown in the software but upon the press of the button nothing happens

 

Part number is: CH-9000221-UK

 

58f2ccf508.png

Link to comment
Share on other sites

On windows 7 ultimate x64 its even worse. Installed the software, updated the drivers, firmware, checked all the ports USB 2.0 and 3.0 and the keyboard doesn't work at all, it works only in bios mode 8, it lights up but its not detected by software, is detected by windows and the scroll light keeps flashing. Is my keyboard broken? I just bought it like 2 months ago maybe.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...