Jump to content
Corsair Community

Not being detected


dreymatic

Recommended Posts

I've tried everything at this point and I'm getting really frustrated with this I've spent 2+ hours trying to find a fix but nothing is working.

 

Recently I reinstalled CUE onto my computer(I had it installed and working 3-4 months earlier) and it won't detect my k95, it detects my mouse no problem but no matter what I try it won't detect my k95.

 

I'm getting extremely irate about this because I can't even change the RBG colors or even think about macroing

 

Things I've tried:

  1. Restarting PC
  2. Unplugging both cables and plugging them back in
  3. Reinstalling CUE
  4. Soft resetting with the polling switches
  5. Trying the new beta version of CUE

All to no success

 

Please help if you can.

Link to comment
Share on other sites

I am having the same problem! One day my keyboard was working the next day it wouldn't accept any inputs. Weirdly enough, the accessory usb port on the K95 works.

 

I have tried the following with no results:

- I have tried the keyboard on another computer with exactly the same symptoms

- I have tried reinstalling the drivers

- I have tried completely uninstalling all K95 related files and then reinstalling

- I have tried plugging the keyboard into all USB slots I have available, both USB 2 and USB 3

 

To me it seems as if the firmware in the keyboard was erased. Once I get home tonight I am going to check to see if Windows 10 updated the night my K95 stopped working. I have read that some input devices stop working after some Win 10 updates.

 

Wish I could help but I am in the same boat and will be monitoring this thread to see if any suggestions help me. I will update if anything changes.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...