Jump to content
Corsair Community

K70 RGB Lighting Issues.


Infected Shogun
 Share

Recommended Posts

Sorry I don't know if this is a CUE thing or a keyboard thing but here goes...

 

noticed three of my keys are a lightish blue now instead of the white that I normally use, popped off the key caps using a keycap remover from my old k70 and no dirt or anything.

 

so I fired up CUE to see if maybe it was a different color but its still white in CUE but blueish on the actual key... (whats up with corsair LEDs always failing somehow?)

 

not the problem tho now because I loaded CUE (I don't leave the process running never have) the windows lock key and light level keys now no longer light up unless I leave CUE always running...

 

tried clearing the color in CUE and redoing everything... sometimes it decides to make the light teal and the lock red/off but otherwise just off/off.

 

how can I get those lights back without running CUE in the background always?

 

additional information: using 1.16.42 with latest firmware, profile is stored on the keyboard itself and does function aside from those two keys and I did read the faq posted and tried that fix.

Edited by Infected Shogun
Link to comment
Share on other sites

Same issue here... My Z key is the most noticeable. It shines yellow. I think the yellow stays on, because as I change color it looks like it's trying match the color I put but still has yellow in it. I rarely ever used my leds, so I think it's a firmware/software issue
Link to comment
Share on other sites

so now the keys in question are even more blue than before, and another key is lighting up green even tho I have it set to not light period.

 

C key, 4, F4 and the Fast Forward button all glowing blue when programmed white with the F key glowing green when programmed to glow nothing. 6 month old keyboard no spills etc... nonsense.

Link to comment
Share on other sites

  • 5 months later...

Usually in a RMA, they do not allow swaps and if they did, you will need to purchase the VENGEANCE/Corsair Gaming keycap set if you want to replace the keycaps that come on the LUX keyboard.

 

You can respond to your ticket and see what options are available to you though.

Link to comment
Share on other sites

so I was randomly doing the hard firmware reset

 

when I put the Keyboard_Clr_EEP_V002.bin onto the keyboard then plugged it back in, all of the lights showed correct, but when I deleted that file and put K70RGB_ISP_V205.bin onto the keyboard they're wrong again...

 

very strange.

 

Hi, i have a similar problem with the C key, can you explain this fix?

 

It seems that my keyboard wants to add more RED than needed (Or less green/blue) the white colour looks like pink where the orange colour looks a bit red

 

PS: I have the K95 RGB

Link to comment
Share on other sites

When I submitted an RMA I asked for the hard firmware reset as suggested in the past by Inheritance.

 

I don't know if your model supports the function so you should submit a ticket.

 

also it wasn't a fix, I think something shorted inside which is why it randomly works fine but then randomly doesn't, its also making a faint coil whine sound.

 

sometimes just cycling the brightness makes them go back to the correct color.

Edited by Infected Shogun
Link to comment
Share on other sites

I too have a similar issue my "R", "T" and "Num Lock" keys have a tint of color to them, when my K70 is set to all white. :sigh!: I submitted a support ticket, I'm still waiting to hear back. Edited by JoeMB
Link to comment
Share on other sites

  • Corsair Employees
so I was randomly doing the hard firmware reset

 

when I put the Keyboard_Clr_EEP_V002.bin onto the keyboard then plugged it back in, all of the lights showed correct, but when I deleted that file and put K70RGB_ISP_V205.bin onto the keyboard they're wrong again...

 

very strange.

 

This is odd. EEPROM should reset the keyboard. After you install 2.05, press PAGE UP and PAGE DOWN when inserting USB. This should clear it too.

Link to comment
Share on other sites

  • 2 weeks later...
When I submitted an RMA I asked for the hard firmware reset as suggested in the past by Inheritance.

 

I don't know if your model supports the function so you should submit a ticket.

 

also it wasn't a fix, I think something shorted inside which is why it randomly works fine but then randomly doesn't, its also making a faint coil whine sound.

 

sometimes just cycling the brightness makes them go back to the correct color.

 

Hmm i just RMA'ed it. Waiting for a replacement atm.

Link to comment
Share on other sites

  • 1 month later...
  • 2 years later...
Sorry I don't know if this is a CUE thing or a keyboard thing but here goes...

 

noticed three of my keys are a lightish blue now instead of the white that I normally use, popped off the key caps using a keycap remover from my old k70 and no dirt or anything.

 

so I fired up CUE to see if maybe it was a different color but its still white in CUE but blueish on the actual key... (whats up with corsair LEDs always failing somehow?)

 

not the problem tho now because I loaded CUE (I don't leave the process running never have) the windows lock key and light level keys now no longer light up unless I leave CUE always running...

 

tried clearing the color in CUE and redoing everything... sometimes it decides to make the light teal and the lock red/off but otherwise just off/off.

 

how can I get those lights back without running CUE in the background always?

 

additional information: using 1.16.42 with latest firmware, profile is stored on the keyboard itself and does function aside from those two keys and I did read the faq posted and tried that fix.

i'm having this same problem, i am using the k70 rgb mk2 se. it just started occurring today and i have tried to soft reset my keyboard but it just doesn't seem to work.

The only colors that show up on my keyboard now are blue and green and any mix of the two. I no longer have red, orange, yellow or purple or anything in between those.

I have no clue what to do and i really don't feel like buying a new one because this is a pricey keyboard.

I fixed it once when i very first reset it but now it won't even show any other colors. it's also saying that my profiles my be corrupted and i don't know if i can reset those or not.

I am running the most recent software on iCUE, which is 3.22.74, but i don't think that has anything to do with it. Are there any other tips or tricks to help me get the colors back to my keyboard?

 

Do i need to hard reset my keyboard or what? Like i said, i really do not feel like buying another one of these keyboards

Link to comment
Share on other sites

  • 1 month later...
I've been having a similar issue with my K95 RGB Platinum - some of the keys were showing a different shade than the others. So, while getting the serial number off the bottom, I noticed that turning the keyboard over had caused another couple of keys to display the same symptoms. So, I gave it a really good shake and all but one of the keys are now working properly. No idea what's going on but could the issue be down to poor connection between the keys and the circuit board?
Link to comment
Share on other sites

 Share

×
×
  • Create New...