Jump to content
Corsair Community

Where to download keyboard firmwares?


pleiades

Recommended Posts

I get this message when I hit the "Check for Update" button. I'm currently running version 2.3.74

That's normal, CUE 2 is currently in BETA and the update checker links to the stable version which is currently lower (1.16.42). This is why you see the error.

Link to comment
Share on other sites

Oh sorry, my mistake. I read your last reply without without reading again the first one and thought you were talking about CUE updates (not FW ones).

 

The error you see while checking for a FW update indeed points to a problem with your connection.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...