Jump to content
Corsair Community

New PSU won't power up when peripherals are connected


ptaylor999

Recommended Posts

As the subject line (plea for help) says, my brand new Corsair RM550x power supply will not boot when there are any peripherals connected to it. Not even just one! I've tried connecting the peripherals one at a time, but even one, no matter which one, cause the power up to fail. No blue light, no fans, nothing. However, when it is connected only to the ATX and CPU on the motherboard, I get a blue power light and the fans all start spinning.

 

This is for an HTPC, so I can't imagine 550W is not enough for three hard drives, a blu-ray player, and a sata controller.

 

I am wondering, could this be a motherboard issue? Would the computer power up at all if the motherboard were damaged? The reason I ask is because I am replacing a PSU that died a few days ago. I heard a loud POP, and the whole unit shut down. I did the paper clip test on the PSU and yep, it was dead, I then tried a EVGA SuperNOVA 750 B1 80+ BRONZE PSU, but it died as soon as I powered it up (all peripherals connected), with a wisp of smoke drifting out of the PSU itself. Thining and hoping I just got a faulty PSU, I purchased the Corsair. So, this is my third PSU. It has not blown up, but it will only power up when there are no peripherals connected.

 

I have looked at both sides of the motherboard and it looks fine. No black marks or melted solder anywhere that could be causing a short, as far as I can tell anyway.

 

I'm at my wit's end and could sure use some expert advice.

 

Thank you!

Link to comment
Share on other sites

If the 2nd psu died as soon as you connected it there's an issue somewhere else 100%.

 

Thanks for your reply.

 

I would normally think that the issue is with the motherboard, but considering it looks fine and seems to boot up fine with only ATX and CPU power connected, I wonder what else it could be.

 

Any ideas? Advice for finding out?

Link to comment
Share on other sites

  • Corsair Employees

I'm with the first PSU killing a few components. The reason the EVGA went up in smoke too is because it doesn't have the proper safety protections built into it to prevent it from committing suicide. The RMx is sensitive enough to whatever short you have to shut itself down to prevent further damage.

 

So you say it won't "boot up" when peripherals are connected. Let's get some clarification. Do you mean it doesn't POST? And does that mean to say that when you have everything BUT the peripherals plugged in, the motherboard actually POSTs? (i.e. you get the POST screen, etc.)

 

Big difference between a built that POSTs versus a build that simply powers up.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...