Jump to content
Corsair Community

3 week old M65 Double Clicking and about to meet a sledgehammer


Recommended Posts

So my old wireless Rat 9 finally took a dump after years of use. I already owned a Corsair headset(Void Gaming RGB) and a keyboard (STRAFE MX Brown) so I figured go complete the set and buy the mouse. I bought it 3 weeks ago yesterday and it is double clicking on an off. I've done some of the "fixes" I've read about online and nothing has worked. Getting quite pissed at this point that I even bought it. Anyone have any definitive fixes or ideas?
Link to comment
Share on other sites

Unplugged it, and replugged it

Reintalled CUE, then reinstalled it

Uninstall, restart, install, reboot

Checked firmware

Tried other USB slots

Checked on other computers(With and without CUE)

Even checked it on my macbook

I'm sure I've tried more things, but they escape me

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...