Jump to content
Corsair Community

Corsair Void RGB, unknown usb device, invalid device description


Mike199717

Recommended Posts

Hello Everyone,

 

First post here, and i know the title is to long.

Problem is, i just bought an (in my eyes) expensive headset and it doesn't work.

Tried it on my laptop for 2 minutes, worked imediatly.

I then unplugged it, plugged it back in my pc, and started CUE.

I could not connect, so i did a firmware update, that did not work so i let it charge for a while.

Nothing helped, but it charged so i waited for it to turn green.

After the charging i tried to update firmware again, it worked.

then when i tried to connect it, it would not, and after a few attempts it would not turn on entirely.

Now i have a device that won't charge, is an unknown usb device with invalid device description and no way to update firmware or anything.

Hopefully someone can help me.

:wtfeh:

I tried rebooting, i tried to update, i tried earlier Cue software, and i can't think of anything else.

 

Sorry for the post, not native english and bad at writing.

Link to comment
Share on other sites

you could try to re-pair the headset, as in get the headset and dongle to sync together again after the firmware update? also in CUE does it say it is working correctly? & in device manager can you check if the headset is listen as Corsair VOID

 

Thanks

Link to comment
Share on other sites

the problem is that i can't update the firmware, becouse i can not connect the headset with my pc (becouse of invalid device description) so there is no way to do that?

in CUE the usb dongle is found and said to be working fine but it cannot connect.

my headset is not charging or showing signs of life, and i don't know why

it is listed as Corsair VOID RGB wireless gaming headset

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...