Jump to content
Corsair Community

Corsair Scimitar Tracking Lag


carsonwen

Recommended Posts

I posted in another related thread that i had fixed my problem but it turns out it came right back. I am starting a new thread as there seems to be so many problems with this mouse and im not even sure if mine is the same as any one else's.

 

So i got my Scimitar 2 weeks ago and immediately noticed that the cursor lagged or seems to stop tracking every couple of seconds. Its very obvious if i trace circles on my screen, it will track perfectly until suddenly veering off to the side for a split second. Turning the polling rate down to 500hz seems to fix it, temporarily, only to have it come back to a lesser extent a few hours later. Ive tried clean reinstalls of my OS and that also fixes it temporarily. Turning off CUE does not help. Turning off colors does not help. Ive updated the FW many times. I also own a Razer Naga which does not and has never had this issue in the past year that ive used it. So i decided to buy a second Scimitar from Newegg rather than the computer shop where i bought my first one. Same issue with the new one. So it doesnt seem to be a defective unit.

 

I downloaded a program called Mouse Rate Checker, which shows the polling rate of the mouse in real time as a continuous log. At 1000hz setting, The polling rate fluctuates between 800 to 1100 hz, and suddenly it drops down to 0 to 3 hz for over a second, and that is also when the cursor lag seems to occur. This does not occur on my Naga.

 

Any ideas or support would be appreciated.

Link to comment
Share on other sites

  • 1 month later...

I have had my mouse all of 3 days and I am getting the exact same issue. I have downloaded Mouse Rate Checker and am also getting fluctuations between 500-1000Hz, with every so often it dropping to 0-5Hz.

 

This makes general computer usage difficult, and gaming impossible.

 

I have the latest CUE Beta software and believe the latest firmware for the mouse.

 

Does anyone have a solution??

Link to comment
Share on other sites

just posted a new thread on a similar issue. bought the Scimitar last night and it tracks horribly on my Steel Series QCK mouse pad. I thought optical mice were supposed to be great on cloth surfaces? But right out of the box, Scimitar constantly looses tracking on my cloth surface mouse pad. tried a hard surface pad and it works fine.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...