Jump to content
Corsair Community

CUE and Scimitar

Recommended Posts



I'm noticing today that the colored DPI indicator on my Scimitar mouse is now cycling off and on at roughly 10 second cycles. When the LED is on, it will change color depending on the DPI setting I set. When the LED is off, I have no indication the DPI setting has changed until the off cycle completes (other than the speedup of the mouse, of course).


I'm running CUE v1.16.42 and Scimitar firmware v2.03. All the other color zones are functioning normally.


Any clues as to what is going on?


Thanks for the help!

Link to comment
Share on other sites

I've heard this issue before, but i think it was resolved in a firmware update.


Have you tried a different USB port?

Have you tried reflashing the firmware by force flashing it via CUE?



Ever since my last Corsair mouse broke, mice don't simply plug into my computer. The mouse, ANY mouse, will not work until spending 30 minutes trying to reboot twice. It takes so f*****g long because I have ZERO mouse functionality until I can get through the bulls**t Windoze update "feature" when it simply has to phone home and I can't get it to stop...but I digress. :wtfman:


Forcing a firmware update seems to have fixed it. Also, it seems like before my DPI settings weren't actually correct and now they're working more like I thought they should be.


Thanks for the suggestion! :D:

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...