Jump to content
Corsair Community

not working though recognized by software


Tsun4mi

Recommended Posts

Hi there,

 

I have a strange issue here:

The keyboard was working perfectly fine on my windows 10 computer.

 

Now I changed the keyboard to another PC (windows 7) and here is the problem:

 

- The lighting of the keyboard is working. It is also recognized by CUE

- The mute button and the volumn slider are working also

- NONE of the other keys are working. I can't type anything

 

I have tried different USB ports, also tried connecting it to USB 3 (via one cable) and USB 2 (two cables). Updated the firmware.

 

What is this???

Link to comment
Share on other sites

Mine isn't launching either. I go to the windows tab then scroll down to the C tab and click on the CUE icon and I get the hour glass/arrow and then it disappears. But no CUE. And I just did the last update and the RGB lighting has gone back to default. Red with white .
Link to comment
Share on other sites

  • Corsair Employees

If it works on one system, that means that the keyboard is not faulty. Can you try plugging in just the USB with the keyboard icon into a USB 3.0 port again? Please make sure that it's the intel USB ports and not 3rd party like Asmedia etc.

 

There isn't any known issue with your set up.

Link to comment
Share on other sites

  • 2 weeks later...

Nah still not working... I'm waiting for my other PC to return and expect that the keyword will work there again, but this problem is really weird...

 

As I said what's working are the "Mute" key, the Media Control-Keys (Stop, Play, etc.) and the Volume Control. The keyboard is being recognized by CUE and I can also adjust the lightning and stuff.

 

But beside from that, not a single key from the rest of the keyboard is functioning...

Link to comment
Share on other sites

Been sitting here for over two hours now trying to get my wife's new K70 Lux keyboard setup on Windows 7. It's a no go on hers except IT WILL WORK on my machine. We're running the same hardware, just she's on Windows7 for a few more days, while I'm on Windows 10, both are x64. Plugging in the keyboard on her machine makes the key lights come on RED, yet NO OTHER LIGHTS COME ON (numlock).. and CANNOT TYPE. (the one caveat to this is that the board will work perfectly on boot in the UFEI bios on her machine no matter what USB port it's plugged into.. so there's that)..

 

We're both running same version of CUE: 1.16.42

Am able to confirm that whether or not you update the keyboard bios, it still won't work on her pc unless you just keep plugging away at the issue with the keyboard in BIOS mode on the switch on the rear.

 

So, the (not ideal) work around for Windows 7:

Click the back switch onto BIOS setting then start poking the Keyboard plug (not arrow buddy) into every USB port in the back, slowly, one at a time, giving windows 7 enough time to go "OH SNAP WHADDAP" if you get about a dozen Windows 7 boxes in the taskbar "installing" drivers, you'll have to restart...

 

One of them will eventually (hopefully) trigger the Numlock light to come on and the Scroll Lock light will flash. At this point, the keyboard will work but the CUE software won't recognize the board. The board will work this way on restarting, but if at any point you mess with that switch on the back for polling, you'll kill it from working until you put it back on BIOS and pull it out of the port it works on and plug it back in.

 

This is all I got, but it's a start, and honestly I'm erring on it being a Windows 7 issue. But it doesn't make one happy to pull the trigger on an expensive keyboard and mouse setup for her tonight to have to play troubleshooter when it was to be a gaming then loving night. :mad:

 

Temp Fixed:

A bit over 24 hours later my wife was messing with it and got it working fully on her PC by plugging it into a front USB 3.0 port on her pc that's connected to the front port header pins on her motherboard. Damn thing fired up like no issue at all, software finally recognized it on her machine and she's very happy, and by extension I'm very happy. Waiting until last second to upgrade her machine still to Windows10.. mainly for the entitled upgrade key I guess, we've already cloned her drive if she wants to stick with Win7.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...