Jump to content
Corsair Community

Can I control 3 pin fans with voltage in corsair link?


MidnightNarwhal

Recommended Posts

  1. When you say H100i do you really mean H100i or is it a H100iGTX or a H100iV2?
  2. The limitation is not the software, but the hardware.
  3. 3-pin voltage fans can be controlled when connected via a CL Mini.
  4. 4-pin PWM give far better control so I always use 4-pin PWM other than on my test hardware.

Link to comment
Share on other sites

  1. When you say H100i do you really mean H100i or is it a H100iGTX or a H100iV2?
  2. The limitation is not the software, but the hardware.
  3. 3-pin voltage fans can be controlled when connected via a CL Mini.
  4. 4-pin PWM give far better control so I always use 4-pin PWM.

 

1. Yeah, the original h100i.

2.

3. Well then I think I'll pass.

4. I mean, both ways I can control the fan the same way.

Link to comment
Share on other sites

I assume after setting 500 you pressed [Apply] and to me the speed looks to be slowly dropping. What did it eventually drop to?

 

I just tried with my H100i and got as below. Maybe it depends on the fans, which ones are you using?

 

attachment.php?attachmentid=25760&stc=1&d=1467054829

1443277568_CL4FixedRPMon3-pinfan.png.22c67dfd95edb2d6bc72e693fc6b6d0c.png

Link to comment
Share on other sites

I assume after setting 500 you pressed [Apply] and to me the speed looks to be slowly dropping. What did it eventually drop to?

 

I just tried with my H100i and got as below. Maybe it depends on the fans, which ones are you using?

 

Setting it to 500 RPM the lowest it goes at is 1236 RPM.

 

I'm using some Corsair SP120 fans I bought. Not the ones that came with the rad.

Link to comment
Share on other sites

What firmware does the H100i have? It should be 1.1.3.

 

Are you running ASUS AI Suite or Fan Xpert at the same time as CL4? If so then you should not be as all the ASUS software fails to correctly interlock access to the sensor hardware.

Link to comment
Share on other sites

What firmware does the H100i have? It should be 1.1.3.

 

Are you running ASUS AI Suite or Fan Xpert at the same time as CL4? If so then you should not be as all the ASUS software fails to correctly interlock access to the sensor hardware.

 

Firmware is 1.0.5 .

 

Yeah I am. What do you mean it fails to interlock?

Link to comment
Share on other sites

Also what exactly does the interlock mean? I checked and like, what does it do.

 

When correctly used it means that both programs don't ask the hardware to do conflicting things. See https://en.wikipedia.org/wiki/Semaphore_(programming).

 

Much of the time there is no conflict, other times the conflict is not noticed but sooner are later things go wrong.

 

See http://forum.corsair.com/forums/showthread.php?p=853586 for an example of what happens when an interlock is not used.

 

Note the CL4 interlock is a poor implementation as it uses a binary semaphore when it should use a mutex, see http://www.geeksforgeeks.org/mutex-vs-semaphore/. To work around this Tamas and I had to use a mutex to interlock access to the semaphore which is crazy. CL4 has no such workaround and simply locks up, see http://forum.corsair.com/forums/showthread.php?p=854006.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...