Jump to content
Corsair Community

Corsair m65 RGB not detected in corsair utility engine


Absorbants

Recommended Posts

  • Corsair Employees

Have you tried another usb port? Even without CUE, the mouse should function as a plug and play. Does the mouse not work at all for you? Sometimes it may take while for your system to detect the mouse as it may be downloading drivers on the windows side.

 

Do you have another system to test the mouse on?

Link to comment
Share on other sites

I plugged it in another port all day yesterday and it still isnt being detected in the software. I also restarted my computer. The mouse itself works but I want to edit some settings in the software but it won't detect my mouse :(
Link to comment
Share on other sites

  • Corsair Employees

I would check to see if there are any USB driver updates for your system. Is this plugged directly into the usb ports on the mobo? Please also make sure they are not 3rd party.

 

If you are still experiencing issues, give our tech support a call. They might be able to determine if the mouse is faulty or not.

Link to comment
Share on other sites

  • Corsair Employees

Ahhh your context stating M65 RGB made me think of the latest version. It did not come across my mind that you might have purchased an older version. Glad it worked out. Since you purchased the older version, is this accidental?

 

The NEW M65 Pro RGB has an updated sensor and surface calibration that may be worth checking out.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...