Jump to content
Corsair Community

Corsair k95 rgb all macros stop working, but lighting and profile detection work.


Recommended Posts

I have had a couple of instances now, where all the assigned macro/G Keys, and key rebinds for all profiles will stop working. When I switch applications the keyboard's lighting correctly changes to the lighting pattern defined for that application, but no macro button will work. The regular keyboard butts which have their generic/original assignment work fine, but nothing that has been reboad or has a custom function/macro assigned to it.

 

I have tried closing the corsair utility engine and restarting it, but it has no effect. The only thing that fixes it, is restarting the computer at which point it will be fine again.

 

Does the k95 use a service or is there any other process, besides Corsair Utility Engine, I can try restarting whenever I run into this problem. Restarting the computer is a pain, especially when your right in the middle of something.

Link to comment
Share on other sites

  • 1 month later...

Having the same kind of issues here, and it really is a problem as reinstalling/repairing will not solve it permanently and restarting the PC is not really an option most of the time.

if all I did on this computer was to surf the web and games sure I could restart anytime.

at least the macros on my mouse "works" (they work but some off them are iffy and due to a calibration issue can go on a rampage)

 

oh BTW all text input actions work but not keystroke or macros

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...