Jump to content
Corsair Community

Strafe non RGB Can´t update Firmware


zug0

Recommended Posts

Hello All,

 

I'm from Brazil, I had a k70 rgb but the leds started to die. After 4 months and no expectation of getting a new k70 BR RMA proposed a new strafe mx red (non RGB) + a sabre rgb mouse. I found a good deal.

 

The strafe arrived today, I plugged in, no issues (I even like it better than my k70).

 

The only issue is that it's impossible to update the firmware, I had 0 issues updating my k70 firmware, but this keyboard is impossible to do so. I tried everything: usb 3.0 only plug, two plugs usb 2.0, multiple versions of CUE, reboots, compatibility mode, running as admin, etc). I'm running windows 10, all updates.

 

, the keyboard came with firmware 1.27. I downloaded all CUE version on the faq, none can update the firmware to 1.30 or 1.33. I downloaded the 1.30 FW zip, but I don't know how to use the bins there. Couldn't find anywhere. And the newest cue version that detected my Keyboard is 1.7.106 (on this version I CAN'T select a firmware file).

 

I won't send this over again to corsair... since I really don't need CUE (I don't need macros, i just wanted a nice backlit cherry mx red keyboard) i'm almost just using this without the CUE software simply because there is no use for me. With the newest version of CUE it says to do a "Force Update from the Server" but there is no such option...

 

My first question is: Since the kb is working flawlessly and I don't need CUE should I struggle with this? Or just simply ditch cue and be happy?

 

Second: here is the logs if someone can help, but it doesn't change much from other stuff I browsed here and none solution worked for me:

 

[2016-06-04T00:59:33]: UserSessionInfo: locked changed to 0.

[2016-06-04T00:59:33]: UserSessionInfo: connected changed to 1.

[2016-06-04T00:59:33]: UserSessionInfo: local changed to 1.

[2016-06-04T00:59:34]: UserSessionInfo: locked changed to 0.

[2016-06-04T00:59:34]: UserSessionInfo: connected changed to 1.

[2016-06-04T00:59:34]: UserSessionInfo: local changed to 1.

[2016-06-04T00:59:35]: Device profile (meta) for device vid=264a pid=1006 not found.

[2016-06-04T00:59:35]: Device profile (meta) for device vid=264a pid=1006 not found.

[2016-06-04T00:59:35]: Device profile (meta) for device vid=a5c pid=4503 not found.

[2016-06-04T00:59:35]: Device profile (meta) for device vid=264a pid=1006 not found.

[2016-06-04T00:59:35]: Created new device object: STRAFE; ready: 0

[2016-06-04T00:59:35]: Device profile (meta) for device vid=a5c pid=4503 not found.

[2016-06-04T00:59:35]: Device profile (meta) for device vid=9886 pid=4 not found.

[2016-06-04T00:59:35]: Device profile (meta) for device vid=a5c pid=4502 not found.

[2016-06-04T00:59:35]: Device profile (meta) for device vid=264a pid=1006 not found.

[2016-06-04T00:59:35]: Failed to open device: vid=1b1c pid=1b15 path=\\?\hid#vid_1b1c&pid_1b15&mi_01&col01#7&19730bc8&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}

[2016-06-04T00:59:35]: Device profile (meta) for device vid=9886 pid=4 not found.

[2016-06-04T00:59:35]: Attached to device object STRAFE: b=1 a=1

[2016-06-04T00:59:35]: Attached to device object STRAFE: b=1 a=0

[2016-06-04T00:59:35]: Initializing STRAFE...

[2016-06-04T00:59:35]: Failed to open device: vid=1b1c pid=1b15 path=\\?\hid#vid_1b1c&pid_1b15&mi_00#7&1af7f83&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}

[2016-06-04T00:59:35]: Initialized (st=1) STRAFE.

[2016-06-04T00:59:35]: Device insertion processing complete for STRAFE.

[2016-06-04T00:59:43]: Firmware Update: started 'C:/Program Files (x86)/Corsair/Corsair Utility Engine/fwupd path=\\?\hid#vid_1b1c&pid_1b15&mi_03#7&2e3b6fbc&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030} image=C:\Users\zug0\RD9864.STRAFE_APP_V204.bin.it9864 usb-vid=1b1c usb-pid=1b15 hid-up=ffc2 test-storage=true' (2).

[2016-06-04T00:59:44]: Firmware Update: tool exit code: 3, exit status: 0. Normal stop: 0

[2016-06-04T01:05:55]: Firmware Update: started 'C:/Program Files (x86)/Corsair/Corsair Utility Engine/fwupd path=\\?\hid#vid_1b1c&pid_1b15&mi_03#7&2e3b6fbc&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030} image=C:\Users\zug0\QL9864.STRAFE_APP_V204.bin.UR9864 usb-vid=1b1c usb-pid=1b15 hid-up=ffc2 test-storage=true' (2).

[2016-06-04T01:05:56]: Firmware Update: tool exit code: 3, exit status: 0. Normal stop: 0

[2016-06-04T01:05:57]: Firmware Download: Aborting idle process not supported.

Link to comment
Share on other sites

Only to update, the only way to update the firmware was to do it on my wifes laptop. That did the trick and now i'm on 2.04. No issues whatsover. Guess it maybe be something with win10.

 

Regards all.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...