Jump to content
Corsair Community

Some keys randomly don't work when typing


Jeffee

Recommended Posts

I don't know if it started when I updated firmware but it I noticed it when playing a game, its been going on for over a month now. First it was the S key and then the W key and then the R key. Now its the E key which happens the most as its a vowel. When the problem moves to a new key the previous key no longer does it.

 

The lighting on the key doesn't issue its lighting pattern when the key is pressed when it doesn't work either. Cue status: Works normally.

Things I've tried:

Cleaned keyboard, Re-installed CUE after uninstall with revo, Re-installed Firmware (latest: 2.04 w/ bootloader 0.09), Clean re-install of windows 10.

Cant find older versions of firmware and I don't know if its possible to reset the keyboard to a factory default to see (had to hit the E key around 10 times for those two E's) if its the firmware.

Link to comment
Share on other sites

Have you tried a different USB port?

Have you tried the keyboard on another computer? Does it work fine?

Latest BIOS, chipset drivers, Windows updates, etc?

 

Trying another usb port now. Haven't tried it on another computer as its completely random when it happens, it has gone a few days not doing it before and the other computers (laptops) don't belong to me but the next time it happens I'll try (didn't happen once while typing this).

Bios, Windows update, drivers are up to date.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...