Jump to content
Corsair Community

H115i cooler mount not level enough


InAUGral

Recommended Posts

Hi,

 

I made an account just to post in here before submitting anything for warranty.

 

My H115i arrived on Friday and after installing it over the weekend I notice the cooler and bracket that sits on the CPU is not contacting the CPU surface properly. This results in high CPU temps in the 90's which it passing the heat threshold of 95 and shutting down.

 

The screws and standoffs are all screwed in as far as they go yet I have to push down on the top right corner for my CPU to not get hot. It seems there is a very small gap between the cooler unit and the metal bracket underneath. This small gap is not present on the other 3 sides.

 

Anyone have any suggestions?

 

FYI I have a socket 2011-3 (with a i7-5930k) on an X99A gaming 7 motherboard.

Link to comment
Share on other sites

You don't need the backplate on socket 2011 or 2011-v3. Make sure you are using the proper standoff screws from the kit and they should screw directly into the pre-existing holes on the MSI board. If it isn't incredibly simple, you may have the wrong stand-off installed. This is my favorite thing about the socket, you can take the pump block on and off in seconds.
Link to comment
Share on other sites

I am definitely using the right standoffs. The bottom end of the screw is fatter for the 2011 and the screws fit perfectly. Gotta be up for an RMA as it cant be held down at all via the screws and bracket.
Link to comment
Share on other sites

The only way I can imagine this is if the "ring bracket" that goes around the pump block is visibly bent and I suspect you would have mentioned that. Even then, the retaining ring bracket should not affect the contact between the cold plate and the CPU lid.

 

When trying to install it, get each thread started while putting pressure on the center. Then gradually tighten each screw a little at a time, alternating between screws until all 4 are tight. If you tighten down one corner all the way, you can put enough tension on the retaining ring to prevent the opposite corner from getting all the way down. This is the only other thing I can think of.

 

If it doesn't work, the RMA portal is on the main page here. You will need to create an account. However, if this is a new purchase, I would recommend exchanging it through the vendor. It would be faster and probably more convenient.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...