Jump to content
Corsair Community

HX850 Won't Power System


Phynomtalk

Recommended Posts

Okay, I saw some very similar threads, but not exactly the same. If there is one exactly, then please forgive me with this one, but I am desperate for help.

 

I have had my HX850 for a few years now, and it has pretty much performed flawlessly up until recent. Problem: system will not start with this power supply. It started about a month ago when I came home from work and tried to wake my system using the mouse and nothing happened. I figured that the maybe my home had lost power. So, I pressed the power button, but nothing happened. I flipped the power switch on the back of the PSU off and back on, and the fan LED's flashed and fans spun for like a tenth of second, and then nothing. I unplugged all my harddrives and plugged them one by one, starting with the one containing the OS, of course. It fired up!

 

The system stayed on for a bit, it all happened again. I tried and doing the same with harddrives again, but this time, nothing. The fans and lights bleep on for a millisecond, and then nothing.

 

Up until the writing of this, I have tried the paper clip test, which was successful; however, my system still won't power on, not with this PSU anyway. I have an older 650 watt power unit which did power up my system. So at this point, I am inclined to believe it is the PSU that seems to have malfunctioned.

 

Please help me with some other options....thanks in advance.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...