Jump to content
Corsair Community

Windows 10 and reflashing M60 mouse


ugnius40

Recommended Posts

Hi,

 

All I have gathered, Vengeance M60 flash utility does not work on Windows 10.

But I have no access to any non Windows 10 computers.

 

Is there any way around this? Like using VMWare with Windows 8 install, compatibility mode, or even some Linux trickery.

 

I need to re-flash my mouse because it stopped working properly - funnily enough - after installing Corsair software on clean windows 10 installation.

It used to work properly without any drivers in Windows 10, and even Linux. Now it only works with corsair software under windows, else clicks do not register, DPI buttons do nothing. Under Linux scroll and right-click registers as left-click.

 

I've quite grown to use this mouse, it has perfect tracking. I would not like to bin it yet, as it's not completely bricked. Is there anything I can do?

 

Thanks

Link to comment
Share on other sites

  • Corsair Employees

We apologize, but the only way to flash the firmware on this unit is with an older OS. We have not tried using VMware to flash, so there is no guarantee that it will work.

 

If you love the M60, I have good news for you. The M65 Pro RGB is basically a newer version of the M60 with a better sensor and better placement of the sniper button that works with WIN10

Link to comment
Share on other sites

Thanks for reply,

 

Will have M65 RGB on the radar.

Meanwhile I've tried to use flashing utility on Windows 8.1 portable USB install, and it failed with same error (Set firmware update mode failed!). So I'm not sure I can fix this even with other Windows OS'es. Very sad to lose my trusty mouse, may be I will sell it for pennies on E-Bay.

Link to comment
Share on other sites

Success! Was able to re-flash my mouse, all back to normal now, writing from Linux. Will skip Corsair software on Windows 10 this time.

 

Used same portable Windows 8.1 installation, but this time I used my HTPC to boot the the stick on. Had to follow guide on flashing firmware to the letter, and run flash utility in Administrative mode.

 

So for anyone having similar system. Looks like new motherboard, chipset (Z170), or Skylake CPU prevents Windows 8.1 from flashing firmware properly.

Mouse just fails to reconnect to computer when flashing utility tries to initiate flashing mode. You get "Unrecognised USB Device (Device Descriptor Request Failed)" error and you have to re-plug the mouse.

 

Thanks,

 

Not sure how to mark this thread as [sOLVED]

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...