Jump to content
Corsair Community

Yellowjacket broken charging cable?


Kicke02

Recommended Posts

Today when I picked up my Void Yellowjacket I realized that the charging indicator on the mic wasn't on. I turned on the headset and saw that the corsair logo didn't light up in red which it usually does while charging. This got me wondering, is my charging cable broken? The CUE only shows a question mark on the battery level?
Link to comment
Share on other sites

do you have it paired with the dongle and is the plugged into usb port? The battery level will show a question mark if it isnt paired or dongle isnt connected.

 

The dongle is connected to the computer and paired with the headset. The headset is connected to the computer with the usb cable but doesn't show any signs of it charging. I can use the device without any problems but it will soon run out of battery and then there is no recharging

 

Edit: The CUE now shows the battery level of the headset.

Link to comment
Share on other sites

  • Corsair Employees
The dongle is connected to the computer and paired with the headset. The headset is connected to the computer with the usb cable but doesn't show any signs of it charging. I can use the device without any problems but it will soon run out of battery and then there is no recharging

 

Edit: The CUE now shows the battery level of the headset.

 

What did you do differently that made the battery level show? Or was it just a matter of reconnecting it?

Link to comment
Share on other sites

What did you do differently that made the battery level show? Or was it just a matter of reconnecting it?

 

It was just a matter of reconnecting it. It seems that the battery level doesn't change. The CUE has shown 99% the last 24 hours

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...