Jump to content
Corsair Community

Many/Different issues


Thrillofit

Recommended Posts

Hello guys!

 

So my K70 RGB is starting to act strange again. It starts with when i'm shutting down the computer. the RGB is still on work with the profiles I have. or not really mine but its the default which is all red and the "WASD" is white. And the rainbow profile. All this is on when the computer is shutdowned which I'dont really like since it's using the LED non-sence. this is the first problem.

 

The second this is that almost everytime I am starting the computer. the keyboard doesn't work and it pops out that I need to update to version 2.04 which gets me stuck on 3% everytime. and What I have to do is to go back to the computer. Remove it from the USB port 2.0 (both) and then put it in to make a update. Its really annyoing to do this process all the time. I have tried remove the software program and nothing.

 

Still the same issue and I need you guys to help me out what to do to make these things to work without having any issues. Please help me!

 

 

EDIT:

 

Im using Windows 10, 64 bit. Z97-ar motherboard, GTX 970, 4790K if this information is needed :)

Link to comment
Share on other sites

  • 2 weeks later...
Make sure you're using the latest software version. (Currently 1.16.42)

 

Use a USB3.0 port but just use one cable (keyboard icon).

 

Try updating then. Update USB drivers with motherboard manufacturer if needed.

 

Nope, Unfortunately it did not work. I'm still getting the problem and I know when. Whenever I close the computer, I always turn off from PSU which kills the full power. So whenever I start the PSU the keyboards starts automatic which turns the full red and "WASD" white as a starnard. so whenever it turnes to another color like rainbow. Then I can't use it anymore. I have to take it off from USB. What is the main reason?

Link to comment
Share on other sites

  • 3 weeks later...

1. That is demo mode running i think.

 

Make sure you turn off the USB ports when the computer is shutdown. You can find this in the UEFI/BIOS. Or you have plugged the keyboard into a powered USB port that is used for charging devices.

 

2. Is the keyboard on firmware 2.04?

Link to comment
Share on other sites

1. That is demo mode running i think.

 

Make sure you turn off the USB ports when the computer is shutdown. You can find this in the UEFI/BIOS. Or you have plugged the keyboard into a powered USB port that is used for charging devices.

 

2. Is the keyboard on firmware 2.04?

 

I dont really know how to turn off the USB ports when the computer is shutdown :/.. Tried but couldn't find it.

 

And yes, its 2.04.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...