Jump to content
Corsair Community

Mouse acceleration on Corsair Sabre since the last firmware update


Adzen
 Share

Recommended Posts

Hello,

 

Since the last firmware update, I experience a different sensitivity with my Corsair Sabre. It feels like some sort of mouse acceleration.

I haven't touched anything in the settings yet my mouse behaves differently.

So I tried to decrease my DPI (I was at 1500, now at 1250), but the feeling remains. I tried lower values but it didn't fit me.

Now it's not a drastic difference, but enough for me to notice... a little bit annoying.

As before the update, "Improve cursor accuracy" is checked, and "prediction" unchecked.

 

Would you have any idea to help it, or maybe downgrade the firmware to the previous version?

 

Anyways, thank you.

Link to comment
Share on other sites

  • 10 months later...
same problem here since the firmware update 2.02... mice is "lagging" or stopping randomly when moving. I didnt find old firmware to flash :(

 

Having the same issue here. At first I thought it was the mouse surface, but have tried multiple with the same problems.

 

I'm going to flash on old firmware tonight and see if it helps, but extremely frustrating to say the least.

Link to comment
Share on other sites

  • 3 weeks later...
 Share

×
×
  • Create New...