Jump to content
Corsair Community

K70 rgb problem


Leemarvin

Recommended Posts

Hi. Seems I' m unlucky with Corsair keyboards. A year and half ago I had a k95 and I had to change it for this current k70 rgb because of dying leds.

And now I have problems with the k70 rgb. Since more or less a month ago it started to have problems with leds. They do not die, but they can't keep an uniform colour squeme. I tend to use an all white selection and is imposible. Some keys have another colour no matter what. Even the default red and white (wsad) is no longer avaiable. I reinstalled the software, the firmware, and nothing...any idea of how to do a hard reset or sthg? Thanks in advance and pardon my english..

Link to comment
Share on other sites

Hello Leemarvin,

 

Check the USB power connections, keep in mind only 1 USB plug (keyboard logo) is needed for USB3.0 ports and both plugs needed for USB2.0.

 

Try flashing the firmware to see if you can get it restored to its original state.

 

Note: Please don't use a USB powered hub as you may encounter incompatibility or electrical issues.

Link to comment
Share on other sites

Hello Leemarvin,

 

Check the USB power connections, keep in mind only 1 USB plug (keyboard logo) is needed for USB3.0 ports and both plugs needed for USB2.0.

 

Try flashing the firmware to see if you can get it restored to its original state.

 

Note: Please don't use a USB powered hub as you may encounter incompatibility or electrical issues.

 

Hi corsair jay, I' ve done everything you' ve said. What do you think it might be the problem? Is there a hard reset avaiable?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...