Jump to content
Corsair Community

Corsair Strafe and Scimitar issues when Windows first starts


Chaos Bolt

Recommended Posts

Good afternoon everyone,

 

I've been experiencing this issue for quite some time now and I cannot seem to find out why it's happening/how to fix it. Once Windows loads up, before even doing anythng, I get a popup from CUE asking me to choose my language and before I can even hit OK to get rid of the dialouge box it disappears. Then, after a couple of seconds my keyboard and mouse will go unresponsive (all lights go out as well) and then eventually my color scheme for both devices come back and starts working as normal. I'm going to assume this isn't normal behavior so I'm wondering if anyone else has had this issue and was able to fix it. Please keep in mind that this is a fresh install(windows 10, but this happened with 7 and 8.1 as well), drivers updated, latest patches, newest CUE and current firmware for both devices.

 

This isn't game breaking, but it's annoying that I have to wait almost a minute before I can actually start using my computer/devices once Windows loads up when it should be working automatically like my wireless Logitech board did.

 

Any help would be greatly appreciated.

 

 

Thank you.

Link to comment
Share on other sites

try another USB Port...motherboard one versus a case USB port. And try the the other way around. Also try with only one plugged in. See if you experience the same issue.

 

I've tried the different USB ports with no luck, but I haven't tried just using one of the two USBs. I will give this a shot once I get home tonight, thank you!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...