Jump to content
Corsair Community

Weird problem after cleaning


Aetherial

Recommended Posts

Hey guys,

I just cleaned my keyboard and now I have a strange problem.

 

After I was done cleaning, i plugged both USBs back in and the "backlight programming key" was flashing and I couldn't type. I restarted my computer and when I tried to login I noticed that the first row of keys isn't working anymore. (tab key till backslash key, so basically the qwerty row )

After loging in with the onscreen keyboard, i opened a notepad to check if it worked but it was still not working. All the other keys work fine.

I unplugged the keyboard and plugged it back in and the backlight programming key started flashing again. I still had notepad open and noticed that the keyboard is constantly typing qwertyuiop[]\ over and over again. Which explains why I'm unable to use those keys I guess.

Is there anything I can do to fix this?

 

Thanks in advance

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...