Jump to content
Corsair Community

H115i Driver Not Installing, CorsairLink4 Won't Install


moldyspore

Recommended Posts

So I have a H110i in another machine, never had issues. Running CorsairLink4 on there without any problems.

 

On a new build I bought an H115i. Hardware installed fine and seems to be operating normally (temperatures around 30C).

 

The software has been another matter though. In device manager it lists "H115i" under "Other Devices" as if no driver is installed for it. Trying to install the latest CorsairLink4 from the Corsair download section (4.2.2.27) fails, even though it says that it completes. In fact, it doesn't even create the "CorsairLink4" folder that it says it is going to create, and the H115i stays listed under "other devices" with no driver installed in Device Manager.

 

I've tried loading older versions of the software (Versions of 3.0 CorsairLink) and they install and load up but don't recognize the H115i and the H115i still does not have a driver installed after installation.

 

My H115i box did not include any software, all it says on the back is to download CorsairLink from the website. So I am at a loss here. I logged in and checked the KB, but the only article on there that references the H115i is about tube lengths.

 

I am running Windows 7 Profession 64-bit (same as the other machine with the H110i).

 

Has anyone else had this problem? I feel like I am going crazy. Have never had this much trouble getting something installed on a new build before.

Link to comment
Share on other sites

The CoolIT H110i uses the standard HID driver whereas the Asetek H115i uses a special driver that comes with CL4. Only CL4 supports the H115i.

 

Do you have the Windows Driver Package - Corsair Components, Inc. (SIUSBXP) USB (10/30/2015 3.6) installed? See http://forum.corsair.com/forums/showthread.php?p=833695.

 

If in Device Manager you Right/Click and look at Properties what does it report? Have you tried doing Update Driver?

 

You should also add your PC specs to your profile.

Link to comment
Share on other sites

After messing around for a few more hours, it seems that CorsairLink4 doesn't like other versions of .net Framework installed on the same machine, even if it is the version it requires. I uninstalled the version of .net Framework 4.5 I had installed for other utilities I installed previously. Once I rebooted and tried the CorsairLink4 installation again the installation process was completely different. This time it started with the download and installation of .net 4.5, which it hadn't done previously, it then brought up a previously unseen screen that showed the installation as well as confirmed the installation of the H115i driver, so it seems it was able to install properly. I now am able to see the CorsairLink4 interface and see the temperature and RPM readout of the fans attached to the H115i and the motherboard.

 

The strange thing seems to be that I can't control the fan speed of any of the fans, including the ones plugged into the H115i. Even trying to set it manually to 100% or the Max setting, the fans don't spin faster or slower, stuck @ ~1300RPM. The pump changes speed if different profiles are set, but that's it.

 

I've updated my profile with my hardware specs. If anyone knows why the fans might not change speed I'd appreciate any insight.

Link to comment
Share on other sites

  • 4 months later...
I too am running 64-bit Windows 7 Professional. Sorry, but I don't have an answer to your fan speed conundrum. The purpose of my response, however, is to profusely thank you for your solution about killing Microsoft's .NET Framework modules. That is so highly NOT intuitive for me that I would have NEVER solved the problem. I spent hours scratching my head and retrying Link4 installation. Finally, fortunately I alighted on your post. I copied your technique to the letter and installation then worked perfectly. Thank you so much for your insight. Now Device Manager no longer shows a crippled H115i device. It's a shame Corsair didn't offer your technique as part of the installation process (or if they did somewhere, it's a shame I missed it). Thanks again for sharing your fantastic solution.
Link to comment
Share on other sites

This is a footnote to my prior post. After everything was up and running just perfectly, Windows 7 updated my system with 163 (yes, that's a 3-digit number, not a typographical error) updates. After that, CL4 (CorsairLink4) would open showing only its background but no data. Bummer. So I deleted it and also MNF (Microsoft .NET Framework) and reinstalled MNF 4. But then CL4 would not install. ARGHHH! To finish this tale of frustration without narrating all my (mis)steps, I finally installed MNF 4.5.2 and rebooted. I had a momentary heart-stopping shock when Windows 7 started installing even more updates, 27 of 'em. But after the system came up, CL4 installed and now works properly again. Basically.

 

I have two remaining issues.

 

(1) Under Settings under Options when I click on "Choose case image", lo and behold, my case -- the Corsair Carbide Quiet 600Q Inverse ATX Full Tower Case -- isn't even listed! What the heck? Makes me wonder about Corsair's dedication to its software. Maybe the temperature readings are inaccurate because CL4 doesn't address my model. Which may relate to the next point.

 

(2) As part of my cooling system I have the Corsair Hydro Series H115i Extreme Performance Liquid CPU Cooler. As I sit at my computer, the ambient room temperature is 73.6 degree Fahrenheit. CL4 reports my CPU packaged temperature as hovering between 45.1 and 47.5 degrees Fahrenheit. How can that be? Every component in the case has to be warmer/hotter than its outside environment, so how can it be cooler by better than 15 degrees? The H115i is a water cooler, not a refrigerant. Once again, it makes me wonder about Corsair's software reliability. Of course, if I'm wrong on this point, I would be delighted to be corrected.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...