Jump to content
Corsair Community

Problem assign Katar buttons


Dyonight

Recommended Posts

Hi,

 

I have the Katar mouse and when I set the DPI button to be "Back" button, it works a while and then stop doing anything. It doesn't revert to default it compledtely stop working.

 

If I reboot it revert back to the DPI default setting and simply starting the Corsair app reload my settings.

 

There's something I don't understand and would like some help here.

 

Thanks!

Link to comment
Share on other sites

Thanks for your answer!

 

I should add it work pretty consistently in windows explorer/google chrome but does nothing when I want to play Diablo 3 or any game for that matter.

 

How can I get around this permisson thing?

 

I'll search the subject but if you have a short answer I'd love to hear it!

 

Thanks!

Link to comment
Share on other sites

Is it all games or mainly Diablo 3?

 

Do the games have a separate .exe that runs instead?

You can find which .exe is used by opening Task Manager and right clicking the process name > Open file location.

 

Compare that file path to the profile's linked program and see whether they match.

 

I don't think its a permissions error if its working fine in Windows Explorer/Chrome. It would be a permissions error if profiles, settings are reverting back to defaults/not saving.

Link to comment
Share on other sites

oh ok I see

 

I'll check that, I only play Diablo so far so I can tell for other game but you make me realize that I only made a Default setting that I thought would work with everything by default...

 

I first tought that by "saving to the device's memory" would kinda reprogram the mouse internally but it look that it only act as a usb dongle to carry the setting to another computer. That mean that CUE is always intercepting the mouse input data and convert it in realtime.

Link to comment
Share on other sites

By losing the setting, is it resetting to defaults in CUE? Did you also save the profile to the device memory?

 

If i recall correctly, on the Scimitar RGB only the static lighting and DPI values are saved. I'm not 100% sure if its the same for the Katar though.

Link to comment
Share on other sites

you're right I'm not very specific.

 

In the CUE software, all is good and it show me the current assignments which are how I want them to be. Basically I want the dpi button to become "Back", which is interpreted as "Mouse 4" in Diablo 3.

 

When I boot my computer all is good and it always work with windows/chrome without dropout but when I start Diablo it work for maybe 5 minutes and then nothing. The button stop responding as if I wasn't pressing anywthing. Once it stopped responding, I close Diablo and mess around with windows/chrome but the button is broken there too.

 

I tried switching profile/modes, restart CUE but nothing work. Only a complete reboot does the trick.

 

Looks like Diablo doesn't like the Katar mouse.... as the Straffe keyboard respond as it should without any glitch.

 

I made sure the diablo.exe process is the right one and my keyboard seem to think it work as it should.

 

Thanks for your help I really appreciate!

Link to comment
Share on other sites

Well, I unticked "Activate SDK" in Settings -> Program and so far so good! I have the habit of switching form Diablo windowed mode to Chrome back and forth and probably that triggered the problem as both program tried to lock the device... or something ;)

 

If I experience further problems I'll contact Corsair support directly!

 

Thanks!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...