Jump to content
Corsair Community

H105- Radiator Popping Sound


Nhilmyre

Recommended Posts

Hi,

 

Recently built my new rig, everything went smoothly... After playing some D3 today, I noticed that the pump was making a "popping" sound. After some research I have decided to try and get a advanced RMA for the unit.

 

I did notice if I bring the fan RPM down to 75% vice 100% (1570 RPM@75% vs 1790 RPM@100%) via MSI command center, the sound does go away. Still testing the cooling numbers, but wanted to know if this is adequate? Or should I still follow through with the RMA process.

Link to comment
Share on other sites

Do you mean from the pump block? Or somewhere else?

 

If changing fan speed has an effect on the sound, that is probably the place to start. Is the sound consistent and fast paced? Or is it just sort of random every few seconds?

 

I wouldn't want to RMA the cooler to replace the fans, but then a "popping sound" is not common.

Link to comment
Share on other sites

On a H105 you can cut voltage to the pump through motherboard controls to reduce it's speed (although you shouldn't). I wasn't sure if you were referring to it or the fans and H105 pump speed is about 1800 rpm. However, if the popping is coming from the block, I think we're done. RMA the unit and be careful until the express replacement arrives. The pump is not likely to explode, but once it starts making noises like that, it's a steep slope downhill. You can run it at 75% in the meantime, but soon that will no longer be enough and the sound will return.
Link to comment
Share on other sites

Alright thanks, I'll proceed with the RMA process... On a side note, a total system reboot and the popping sound has vanished, even at 1800 rpm, though I don't think I have been on pushing the system long enough to bring it back.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...