Jump to content
Corsair Community

Corsair 780T Case Power LED not working


Recommended Posts

So I just got the 780 T, and it looks great, have installed everything in it with no issues.... apart from the power on/off LED.


All of the front panel switches and LEDs are working fine, and all of the ports and buttons work, including the power button. Except the power button LED does not work.


I just moved from my old case, in which the power LED was working, and I have connected all the connectors to the motherboard correctly-or at least I think so:you tell me.


Is it the connector cables, the LED itself or something else entirely?


Note, I have tried reversing the polarization, using the handy tool that came with the motherboard (it just outlines where the 1 pin and 2 pin connectors go), putting them in upside down and jiggling them around, removing them and reversing them whilst the PC is on to see any flicker of hope but nothing has changed.





Link to comment
Share on other sites



I think it most likely it is mostly wrong with the connections. I've personally had this problem many times after moving switching motherboard. Have you tried reversing or flipping the connectors? I would just double check with your motherboard settings and see if you've correctly aligned the connections.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...