Jump to content
Corsair Community

Corsair void wireless Linux


ImtheBest
 Share

Recommended Posts

Does anybody know this works on linux Ubuntu based distribution. I tried my corsair void with the wireless adpater plugged in the USB and turned my void headset on but everything seems to be locked up can't click nothing with my mouse.

 

Do i have to do anything to get this to work with linux before hand. I'm also running the scmitor mouse and strafe salient keyboard both RGB with ckb unofficial software

 

 

Thank you

Link to comment
Share on other sites

I'll just copy and paste from a previous thread about this same problem I had initially using Arch:

 

Yes, it does work, but it will break your mouse and possibly your window manager. Easy solution:

 

create a file in /etc/modprobe.d/ Call it usbhid.conf and add "options usbhid quirks=0x1b1c:0x1b27:0x0004".... where 0x1b1c is the Vendor ID and 0x1b27 is the Product ID. U can type lsusb in a terminal to double check.

 

Then you need to rebuild mkinitcpio.conf using "mkinitcpio -p linux" as root.

 

After that everything should work fine... maybe not the volume control, but that isn't hardware level anyways and only controls the system master volume and not just the headset. U can simply use a keyboard for that.

Link to comment
Share on other sites

I'll just copy and paste from a previous thread about this same problem I had initially using Arch:

 

Yes, it does work, but it will break your mouse and possibly your window manager. Easy solution:

 

create a file in /etc/modprobe.d/ Call it usbhid.conf and add "options usbhid quirks=0x1b1c:0x1b27:0x0004".... where 0x1b1c is the Vendor ID and 0x1b27 is the Product ID. U can type lsusb in a terminal to double check.

 

Then you need to rebuild mkinitcpio.conf using "mkinitcpio -p linux" as root.

 

After that everything should work fine... maybe not the volume control, but that isn't hardware level anyways and only controls the system master volume and not just the headset. U can simply use a keyboard for that.

 

 

I'm on Ubuntu, so don't think i have to run this mkinitcpio -p linux. do i

 

Also does this work with wireless VOID. And do i need the number for my usb here quirks=0x1b1c:0x1b27:0x0004. How do i know which one is for my mouse

 

Thank you

Link to comment
Share on other sites

Yes you will have to run the mkinitcpio command or Ubuntu equivalent.

 

This works for the Wireless VOID. Run lsusb with the dongle plugged in. Note all of your corsair USB devices. Unplug the dongle, then run lsusb... Which ever one doesn't show up is your VOID device.

Link to comment
Share on other sites

  • 1 month later...
Yes you will have to run the mkinitcpio command or Ubuntu equivalent.

 

This works for the Wireless VOID. Run lsusb with the dongle plugged in. Note all of your corsair USB devices. Unplug the dongle, then run lsusb... Which ever one doesn't show up is your VOID device.

 

I'm with the same issue, which is the equivalent on UBUNTU from command mkinitcpio?

 

Thanks in advance

Link to comment
Share on other sites

  • 3 months later...

Easiest way is to make a file with the following as root:

/etc/X11/xorg.cond.d/10-corsairvoid.conf (you can also put it in /usr/share/X11/xorg.conf.d)

 

# Corsair VOID RGB Wireless

Section "InputClass"

Identifier "Corsair"

MatchUSBID "1b1c:1b27"

Option "Ignore" "on"

EndSection

 

Make sure to put the right MatchUSBID in check with

lsusb with the dongle in.

 

Reboot (easiest)

 

Check if the right soundcard is connected in Sound/Volume.

This works on my desktop and notebook, sofar without issues.

 

Thanks to http://www.c0urier.net/2016/corsair-gaming-void-usb-rgb-linux-fun

 

Cheers

Link to comment
Share on other sites

  • 1 year later...

I just reinstalled Arch and forgot about my original issues with the VOID HS. Probably because I didn't experience any issue's this time!!! WTH. No xorg hack required now? Even the volume works now!

 

Though I did notice some errors in my Xorg.O.log regarding the dongle. So I'm anticipating something not working as I spend more time on this new install.

Edited by Atlantida
Link to comment
Share on other sites

 Share

×
×
  • Create New...