Jump to content
Corsair Community

M95 Vengeance Lost Profiles


NorthernFox

Recommended Posts

So Friday night I was playing games with my mouse working perfectly. Booted my computer up Saturday morning the mouse has quit on me.

 

Turns out somehow I'm guessing the onboard memory died or something, because the mouse has no profile LED's lit, and none of the buttons work at all, not even left or right click.

 

Tried re-flashing the firmware, re-downloading the profiles to the mouse. None of it worked. The computer reads the mouse is there, it moves the cursor on the screen, but the buttons do nothing.

 

I just got it in October 2015. :(

 

Thankfully I've still got coverage from where I bought it (NCIX), but unfortunately they no longer carry the M95. I'm going to have to trade it in for a Scimitar or a Naga, because they don't have the beautiful M95 anymore.

 

It was a perfect mouse as far as I'm concerned. The thumb buttons were oriented beautifully.

Link to comment
Share on other sites

I run Windows 10, tried it on another system (Windows 7), it still didn't load any of the profiles or anything.

 

I did try to reinstall the software that configures profiles etc for it, but that didn't change anything either.

 

NCIX told me to RMA it to them and apparently they're going to send me a Scimitar since they don't carry the M95.

 

Edit: I just created a ticket. Managed to completely forget to do that apparently.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...