Jump to content
Corsair Community

Corsair Link not opening


keebs63

Recommended Posts

Hello all, this is my first time posting here. I've been having an issue with v3.2.5742 for months now where it will only run in the background and will not open to the full program. I've tried opening through the desktop shortcut, startup menu, task bar, and file location, but it always ends up with it appearing to start for a second or two and then I guess crashing or something, though it's always on in the background and I can see it active in the little icons at the bottom right of the screen. I'm running W8.1, I've tried uninstalling and reinstalling multiple times, installing earlier versions, and installing the new version (it says I still have the program despite deleting all the files and using the uninstall program for it). It's running as admin, and I've looked at all of the properties to no avail. I've run out of ideas on how to fix this so I'm asking here. Any help would be greatly appreciated.

 

EDIT: I've also noticed that when I try to open the full program a process from the task manager pops up for a second called CorsairLINK.exe along with the normal process that's always there called CorsairLink.exe.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...