Jump to content
Corsair Community

M65 RGB Help - Too many issues at once


M0rris

Recommended Posts

Hello there,

 

I already owned a M65, however, the sniper button was waaay too far away from my thumb and ultimately, I couldn't reach it. Not a problem actually as I didn't plan to utilise it anyway. The feeling of the mouse made it irrelevant for me.

 

However, as I wanted to use it and also the "backwards" button in League of Legends and The Division now, I went for the RGB model (glad you have swapped the logo again ;) and did so a few days ago. Just for your reference, I paid 69,99€ for it. Fine for me.

 

Before we get into what issues I am still encountering, here are some specs:

 

Windows 10 Home 64bit and updates just went through

MSI Z97 Gaming 7 (USB3 Drivers are up to date)

I think you chaps don't need any more, do you?

 

LED Issues

After plugging in the new mouse and installing the driver (CUE 1.15.36), I was greeted with those rainbow colours...which went offline just a few seconds later. PC restarted and the lighting was back.

 

So I dived into the software and set up the colour profile I wanted. Cool, working fine. After about five minutes....the lights went out again and didn't come back on at all. I had to unplug the mouse and plug it back in to get it back up, just to find out later, that they went out again.

 

So that was the first problem.

 

Profiles & Button Layout

Now about the sniper and backwards button which I wanted to use ingame. Obviously, I would set up profiles for it in order to do so.

Nope, the profiles don't work at all. I setup a profile for LOL and assigned the F and D letter to one of those buttons in a dedicated, not program parented profile. So I switch it manually before starting the game.

Nothing happens. In notepad, you would obviously get the letters F & D upon pressing the sniper and backwards button. Nothing...

 

I repeat the process in the "Default" profile and it works flawlessly. I set up a different mode in the Default profile with the LOL button layout and it works.

When I am in the Default profile and LOL mode and then switch to another profile without switching the mode in the default profile beforehand, it keeps the button layout (F&D). Weird, isn't it?

 

When I set the Default mode in the default profile and then switch to another profile, the buttons don't work again.

 

So I am going to assume, that the profiles don't work at all or that the software doesn't change the profile at all, for some reason.

 

Saved them on the mouse (which is kinda idiotic that you have to do that...just why?) and the same issue occurs. Saving my LOL profile to the mouse, end CUE and nothing...the button layout doesn't work.

 

Updating Firmware

Alright, so apparentely I have to use Firmware 1.20 in order to utilise the full colour spectrum. Well, it runs through, but after updating, it is still at FW 1.19 :D So it actually doesn't go through at all.

 

Does anybody have the firmware image so I could manually choose it from a folder?

 

Yes, CUE is running as administrator. Yes, the mouse is recognised in the Device Manager. Yes, the CUE installation folder has FULL rights.

Yes, I have tried ASMedia's USB 3 and Intel's USB 2.0 ports (which shouldn't be a recommendation in my opinion, just saying).

 

I can use the modes under the default profile to utilise my different button layouts for LOL and The Division, so for the time being, I am fine.

But I want to use profiles and have the lighting ON all the time and not just for a few minutes. At the end of the day, I paid for it and want the product's full performance, not just a few percent of it.

 

Sorry for the insanely long post, but if there's somebody who could help me with this and tell me what I am doing wrong, I would be very grateful.

 

I even have a video of it, if that's help?

 

Kind regards,

 

Phil

Link to comment
Share on other sites

Right so lets start with the LED issue. That issue was resolved with the 1.20 update so lets move on to the updating issue. Have you tried updating it on another computer, or reinstalling CUE? If you cant get it to work you will need to contact Corsair Support for the firmware images.

 

Now for your button issue. If you set up something in default and change profiles the new profile wont have your key binding so it wont work. Saving to device memory only saves static colors and not the macros. CUE must be running for any lighting, or actions to take place.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...