Jump to content
Corsair Community

Mouse doesn't even show up in CUE


Geekin

Recommended Posts

Just bought this mouse and man instant errors. This isn't the first time I've bought something from Corsair with issue's, and buggy software to go with it. I have an h110i that came with software that didn't even function properly.

 

Scimitar RGB Gaming Mouse

 

The mouse itself is laggy/choppy in motion. The software seems to only recognize the mouse every other reboot. I've had plenty of mice with my machine from Steel Series MMO mice, to Razor Naga never had issues until now.

 

Great looking mouse very attractive design which is exactly what pulled me back in, unfortunately it looks like I'll be returning if I can't get this sorted out. It looks as though I'm not alone. I've put a ticket in.

 

Does anyone have a quick fix for this the Profile selection is greyed out. I'm unable to program any of the buttons. The color profiles aren't working. (Sometimes they do sometimes they don't.)

 

Things I've done:

 

Checked cables

Moved USB ports in hopes of the software picking the mouse up by switching ports.

Tried USB 2.0/3.0

 

Nothings worked. I don't mean to sound like a jerk, but it's frustrating to purchase a mouse like this to have the software not work.

Link to comment
Share on other sites

Which firmware do you have on the mouse right now? The laggy/choppy movement was an issue that was fixed with the new firmware 2.00, however, it caused some issues with older motherboards (where it took up to 5+ minutes for CUE to detect the mouse).

 

I am not sure if they removed the FW 2.00 until they fix the issue for older motherboards or not thought, that's why I'm asking which version you have. I do know that Corsair James said they are already testing a new FW with a fix for the problem I just mentioned , it will take 2-3 weeks according to him. His post was made a few days ago already.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...