Jump to content
Corsair Community

Disable lighting on system lock or screen off


Recommended Posts

I have an M65 RGB and Void RGB with plans to soon get a corsair RGB keyboard (probably k70 with browns). I can't seem to get my mouse RGB to turn off when my system locks. I leave it on all day and prefer not to have the lights blasting all night since it is also in my bedroom.

 

Has anybody figured out a way to do this automatically? Currently I press the button on my K70 with red LED's to turn off the lighting but my mouse always stays on. I have tried pushing a profile to the mouse with all lights off for its default, but somehow it still turns on just white leds instead of staying off. Kind of holding off on the RGB keyboard if this is something I can't do from CUE in the current version. I usually end up just unplugging my mouse right now.

 

I recently purchased the RGB mousepad from a competitor (since corsair doesn't offer one :[pouts: ) and their software allows the pad to turn off when the monitor goes off. This brought this issue I have had for the last year back to my mind. Am I missing something simple in CUE?

 

All my devices are currently plugged into a powered usb 3.0 hub if that makes a difference.

 

Thanks!

Link to comment
Share on other sites

Thanks. I just tried a direct plug into the system. I am still getting the same issues. As a test I turned the mouse lighting completely off. When I lock my system the lights on it turn on completely. It appears that when windows locks it immediately looses connectivity with CUE and will revert back to the last color pattern I had set to it. In this case its red, but it has also done it with green before too.

 

Strangely enough using the unofficial Mac version of CUE on my Mac actually links the lights on and off to the brightness button on my k70 non-RGB version.

 

My hub does some intelligent switching of devices when it notices the system screen off. My mousepad is able to successfully turn off when it detects my monitor going off.

Link to comment
Share on other sites

  • Corsair Employees

Why would you not want to see all the flashing lights?!?!?! jk

 

Here is a workaround you can do so the lights shutoff when you lock your screen:

 

1) Create a new profile in CUE

2) Select your devices, and set all the lighting to black - no light basically

3) Save the profile to device memory

4) Select and resume your usual profiles

 

This will basically makes it so the devices will display no color when they have no communication with the CUE software. If you move the device to another computer, there will be no lighting unless it has CUE installed.

  • Confused 2
Link to comment
Share on other sites

Lol true, but a decked out glowing desk isn't the best for sleeping ;)

 

Thank you so much for the response, that worked great. In my past attempts I had set the color to not selected, and I now realize that's why it was defaulting to white or red when I locked.

 

Now that I have this figured out, the matching RGB keyboard will be coming soon. :)

Link to comment
Share on other sites

  • 2 months later...
Why would you not want to see all the flashing lights?!?!?! jk

 

Here is a workaround you can do so the lights shutoff when you lock your screen:

 

1) Create a new profile in CUE

2) Select your devices, and set all the lighting to black - no light basically

3) Save the profile to device memory

4) Select and resume your usual profiles

 

This will basically makes it so the devices will display no color when they have no communication with the CUE software. If you move the device to another computer, there will be no lighting unless it has CUE installed.

 

I just wanted to say a big thanks, and that you're a genius. I had a similar issue...I uploaded a profile to the mouse which has no lights on, but it still kept lighting up in yellow when I locked windows, but the keyboard didn't :confused: Made no sense at all. The yellow lights on the Sabre would come on even without the Corsair Software running?

 

Anyway, setting it to black and uploading to the mouse has sorted it! How come that goes to no lights then, is it not possible to have a black coloured LED?

Link to comment
Share on other sites

  • 3 months later...
Why would you not want to see all the flashing lights?!?!?! jk

 

Here is a workaround you can do so the lights shutoff when you lock your screen:

 

1) Create a new profile in CUE

2) Select your devices, and set all the lighting to black - no light basically

3) Save the profile to device memory

4) Select and resume your usual profiles

 

This will basically makes it so the devices will display no color when they have no communication with the CUE software. If you move the device to another computer, there will be no lighting unless it has CUE installed.

 

Thanks for the help! Personally I was trying to re-enable the red backlighting when Windows was locked (somehow I disabled it). So in my case:

 

1.) I made a new profile "Switch"

2.) Added a new Mode for a total of two Modes

3.) named one Mode Lock and in the lighting tab set all keys to constant red (no effect).

4.) edited the Default mode to have my preferred lighting (wave).

 

5.) I dragged the Lock Mode above Default Mode

6.) then clicked the icon next to the Profile name and clicked Save Profile to Device Memory.

 

This enables my Lock mode (which now had the little chipset icon next to the name) when my computer is Locked, but switches to Default when I'm logged in.

Link to comment
Share on other sites

  • 1 year later...

Sorry for the necro but I tried this 3 times and there is no option to "save to device memory" anywhere that I can see. so everything is black when the computer is unlocked and it goes right back into demo mode as soon as I lock the cpu.

 

Why would you not want to see all the flashing lights?!?!?! jk

 

Here is a workaround you can do so the lights shutoff when you lock your screen:

 

1) Create a new profile in CUE

2) Select your devices, and set all the lighting to black - no light basically

3) Save the profile to device memory

4) Select and resume your usual profiles

 

This will basically makes it so the devices will display no color when they have no communication with the CUE software. If you move the device to another computer, there will be no lighting unless it has CUE installed.

Link to comment
Share on other sites

unless these are pro devices with on board memory, there is no fix. The software cannot communicate in lock mode with the hardware so it goes to the factory test lighting. If it does not have static lighting at least (which most of the keyboards tend to) but the polaris and the st100 do not

 

Just unplug them if you are watching a movie, or shut the pc down. The cutting edge has sharp edges.

Link to comment
Share on other sites

Thank you for the reply. This cpu also runs the video server, steam games for the kids (well and this kid) and security camera system for the home so I can't shut it down.

 

However, I will just do what I have been doing and throw an old towel over the mouse when the cpu is locked.

Link to comment
Share on other sites

'cant'...and throw an old towel over the mouse when the cpu is locked.

Right I get it, when I used to need a lot of uptime in the past i would put black electrical tape on the front of the st 100 and the polaris. You might like that as well. It never bothered me as i usually use the rear and side lighting on them anyways when unlocked.

Link to comment
Share on other sites

 Share

×
×
  • Create New...