Jump to content
Corsair Community

K70 Keyboard Issues


powrhaus

Recommended Posts

I recently purchased two K70 RGB keyboards. One for me and one for a friend. We've had them for about a week and are both having serious issues. I'm wondering if anyone had has similar issues and knows of any fixes. We're really close to sending them back as some of these are fairly severe.

 

1. Windows 10 sometimes takes up to 45 minutes to to activate the keyboard so we can login. Windows boots normally to the login screen (about 10 seconds), then we wait while the keyboard changes colors, flashes, goes dead, changes to rainbows, goes white/red, etc. All this time, no keyboard input is accepted. I've left the machine for about 45 minutes and still the keyboard is not active. Sometimes mashing keys will hurry the process up, but it still may take up to 10 minutes. I've tried using USB 2 and USB 3 ports and the result is the same. During this time, the mouse is working perfectly, but unfortunately I cannot enter my password with the mouse. A $10 USB keyboard allows me to immediately login.

2. Keyboard does not allow me into BIOS no matter the setting of the switch on the back. I've tried setting it to the BIOS setting and the keyboard doesn't even light up until BIOS is long gone and Windows has already booted. Again, a $10 USB keyboard has allowed me into BIOS without issue.

3. CUE usually always defaults to the first profile in the list regardless of whether I have set a particular profile to default. Occasionally it will select a different profile than the first in the list, but it's always a mystery as to which profile I'm going to get. It is almost never the one I have set to default.

4. LEDs on keys is not very consistent. The number keys above the letters, the keys to the right of the letters, and the keys on the numeric keypad all only light the top-half of the key. In other words, all my number keys (above the letter keys) don't light up the numbers at all...just what you'd get if you pressed Shift first. The same is true for the keys to the right of the letter keys (like .,/;'[]\) and for the number-pad keys (like the arrows, home, PgUp, End, PgDn). These are never lit.

 

I am using the latest version of CUE and the latest version of the firmware for the keyboards on both machines. I have also checked to insure we are using the latest available USB drivers for both machines, and the latest available firmware for both motherboards. Our results are the same.

 

I'm really close to asking for a refund as I've never had issues like this with any other keyboards we've used. The odd fact is that we're both experiencing the same issues using different machines, different motherboards, etc.

 

Any ideas, comments, or suggestions would be greatly appreciated.

Link to comment
Share on other sites

4) Is not really a bug/issue, it happens because the leds are mounted on the top of the key and the bottom gets much less light. They changed the keys font on the Strafe RGB and those get some more light instead for example.

 

As for the other 3 issues you listed, it sounds like you really have some bad issues. A first step would be to uninstall completely CUE and see how it goes, does the keyboard work at all (lighting aside)? Macros or lighting apart the basic functions should work just fine even without CUE.

 

Also, those issues, are both you and your friends having the same exact issues on both computers with both keyboards? Do you both have the same hardware perhaps?

Link to comment
Share on other sites

Thanks for your reply. It's a bummer to hear about the LEDs in the keys. It's odd that they couldn't do something to make them look better.

 

I'll try uninstalling CUE and see what happens and report back here.

 

As far as my rig and my friend's, our basic setup is below. But we are having identical issues. The only difference is that his recognizes the Corsair keyboard a little faster than mine...but not much.

 

MINE - Built in 2009

=============

EVGA X58 Classified 3 motherboard with 24gig Corsair RAM

Intel Core i7 X990 CPU 4Ghz

Crucial MT4 256gig SSD

EVGA GTX 780Ti Superclocked

Corsair HX1000w Power Supply

Windows 10 Pro 64-bit Upgrade

 

FRIENDS - Built mid 2015

================

EVGA X99 Classified motherboard with 32gig Corsair RAM

Intel Core i7 5930K CPU 4.2Ghz

Crucial MX200 512gig SSD

EVGA GTX 780Ti Superclocked

Corsair HX1000i Power Supply

Windows 10 Pro 64-bit Fresh Install

Link to comment
Share on other sites

I just removed CUE. It hasn't made any difference in recognizing the keyboard on bootup. The keyboard continues to turn on and off, cycle through different reds and blues, cycle through rainbow colors, etc. Typing on the keyboard does nothing until the keyboard "wakes up". I typically know when this has happened as it cycles to the red keys with W, A, S, D in white. Once it stays on this color scheme for longer than a few seconds, I know that I can use the keyboard.

 

It does seem that occasionally if I press the spacebar repeatedly or the ESC key, sometimes it "wakes up" quicker.

 

I'll have to re-install CUE to get you the version of firmware as I don't know any other way of obtaining it.

Link to comment
Share on other sites

After playing around with the keyboards quite a bit, we can get them to "wake up" at the Windows login screen if we press the ESC key a couple of times. Once we do this, all the keyboard lights go out, then come back on with all red keys except for the W, A, S, and D which are white. At this point we can login.

 

Still CUE picks a random profile whether we've set one as default and saved it to the keyboard or not.

 

We are also not able to use these keyboards to get into BIOS at all, no matter what the switch is set to. For that we have been using a $10 USB keyboard.

 

It's a bit sad considering how much these keyboards cost. They may still be returned, but we really do like the colored LEDs when the keyboards actually do work.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...