Jump to content
Corsair Community

Corsair void wireless not working at all


Recommended Posts

i've had my corsair void for about 2 months now, every time I install the CUE my headset seems to just fail on me after i click Update Firmware under Device in the CUE program.:mad::mad:


whilst I wait for the bar to update usually about at 97% my windows on the bottom right hand corner notifies me with ( Failed to install, device is not recognised) or something like that..



I've tried to pair dongle with my headset and adapter and it still doesn't work..

I've tried so many methods still nothing.. i waited for a good 3 months for you guys to fix this issue and yet still nothing!!


I also don't even see my headset under the Select Playback under System Sounds either?? so what is there for me to set as a default??



cmon... corsair... pick up your game!!

spent money on a product that doesn't even work!! completely disappointed


Ive been waiting for an update to get this crap fixed, still nothing is done!!

Link to comment
Share on other sites

a few things i wanna post up for extra info


this is the headsets under Device >Properties>General

(Device status)


Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

Link to comment
Share on other sites

  • 3 weeks later...
  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...