Jump to content
Corsair Community

RAM won't boot


Recommended Posts


I have a machine with 6 sticks of Corsair PC-2100 (CM74SD1024R-2100\S) and the machine won't boot unless I remove 2 particular sticks. I've tried several different combinations, and any config with these 2 sticks won't let the machine boot. It turns on but it never reaches the BIOS screen, or displays anything for that matter, that indicates its checking memory or anything. My guess is that they're dead, any suggestions?



Link to comment
Share on other sites

  • Corsair Employees

And have you tried these modules just by them selves? If so and the system will not post then lets get them replaced!

Please send us a email with a copy of the form or all of your info name address and phone# and the Module part# and copy the link to this post and email it to Warranty@corsairmemory.com. Or you can also use the On Line RMA Request Form as well.

If after 1 day or 24 hours excluding weekends you do not get the rma please email the same to rma@corsairmemory.com and we will help to resolve it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...