Jump to content
Corsair Community

Strafe Cherry MX Red problem


w00dst0ck

Recommended Posts

Hi all, I got my Strafe MX Red.

I've tried to link it to USB 3.0 with only the keyboard switch and also in USB 2.0 with both switches and pulggin' in the 2 arrow switch first.

It doesn't work with windows 7-64. It works in bios but not in windows.

CUE can see my keyboard, it tells me it work correctly but it doesn't. Sometimes CUE freeze, keyboard disappears and in few secs appears again and everything seems ok but i can't type! :(:

 

Any suggestion please? I've looked around for a solution but I've found nothing.

 

Thank you.

Link to comment
Share on other sites

Do you have another computer to test this keyboard on? If CUE detects it but it keep disconnecting, it may sign of a bad connection.

 

 

Yes, I've tried on a laptop with windows10 and it works without CUE and on USB 2.0.

 

It seems it's windwos 7-64 faults. But I don't know how to fix it!

I also tried switching between other USB: mouse, heatsed, printer on others port... same result. All but keyboard work correctly.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...