Jump to content
Corsair Community

Problem between CL4 and Aida64


Recommended Posts

Hello there!


i am encountering a messy problem:

Since the last update version of Corsair Link( 3 to 4 ), it seems having a problem with Aida64 (version Engineer 5.60.3716.0)

On Aida64, i use the sensor panel, and the G15 LCD panel (helpful when screens are off to know how is my computer going)


They are both launched on startup, and after a while, CL goes mad about temps and fans, they go too fast for a low temp like 25C, almost 80/85% rpm... And infos given about the PSU are negative, like a "-351231,9 C" ...

That put cpu frequency at max, cpu heat increase, eat more memory time by time, et gets laggy...


And now, if i restarts the CL4, doesn't give any infos about the cpu, motherboard temps and HDDs... And crash after 10/30sec...


If i turn off Aida64, CL seems to work correctly.


Why i use Aida64? Because it gives me infos that i don't have on CL, like Cpu frequency and usage, memory usage,etc...

And for case fans, that CL don't do anymore ( and they were on CL3, which was quite helpful... Why Corsair, WHY it dissapears on CL4 ???:eek: )


Cl4 don't handle case fans, so i use AI suite3 1.03.30. I encounter no problem with it, i tried to turn it off also, no changes. I don't think that comes from here.


So i tried many versions of Aida64, same result... So i stay with my paid version.


Does anyone already had this problem?

Am I missing something?


I have attached my system info and screenshots, it could be helpful ^^


Thank you for your answers !

Kenei System Info.txt

Windows report when CL4 crash.txt




Link to comment
Share on other sites

Am I missing something?

AIDA64 may have difficulty playing nice with Corsair Link running at the same time. This is something we're addressing in a future version.

CL is a future version so why has this not been addressed?


Yes, CL and AIDA64 have difficulty playing nicely

Link to comment
Share on other sites

Thank you red-ray for reply!


I maybe enter a wrong search on the forum... As i see, we are many in the same case...


The thing that i don't understand, is that the CL (3 and 4) were working good with Aida64 engineer/business 5.50.3600.0 before...



So, I decided while waiting for answers to remove both CL4 and Aida64.

Clean remove of files that didn't delete in the remove process.

Restart computer, and fresh install of both programs.

If i launch Aida 5.50.3600.0 first, CL crashes if i launch it after.

If i launch CL first, i can launch Aida 5.50.3600.0 , and it seems to get stable!


Process in task manager seems stable too, no leak memory or high cpu frequency.


If it could be helpful for someone !


If there is some problems, i will reply for those who want to know ^^

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...