Jump to content
Corsair Community

Scimitar STILL not working with CUE (2 weeks)


sbeard90

Recommended Posts

I am getting a little frustrated at this point. I have been on the forums looking for help and it seems that I haven't gotten anywhere. Ever since the new FW or CUE SW update went live, my Scimitar thumb buttons just stopped working. In fact, the CUE software profile is just greyed out. It tells me that my mouse has malfunctioned. What frustrates me the most is that I use it for work (I know its a gaming mouse) and the macros help streamline my responsibilities and I know longer have any of those. This is quite a burden now that I have relied on them for the past few months. Is there any update on the matter?
Link to comment
Share on other sites

GPU : ATI Radeon HD 3450 (Microsoft Corporation WDDM 1.1)

CPU : Intel® Core2 Duo CPU E7300 @ 2.66GHz

Memory : 4.00 GB RAM (3.50 GB usable)

Current resolution : 1600 × 900, 60 Hz; 1600 × 900, 60 Hz

Operating system : Microsoft Windows 7 Professional

 

Its my old work computer. This would explain why it runs fine on my new up-to-date gaming pc at home and not my old dinosaur computer at work.

 

EDIT: Oh sweet baby jesus, this worked and everything is back to normal. Thank you so much!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...