Jump to content
Corsair Community

Corsair scimitar need help


Recommended Posts

Hey Guys,


So less than 10 hours ago, i just bought a Corsair Scimitar mouse brand new.

After plugging it in, the led lights seemed to be working fine and so does the LMB and RMB and the Scroll wheel. I downloaded the CUE software, had it installed and updated the firmware and all you know the drill. It turns out the profile button on my CUE software is greyed out (Unclickable) so i'm unable to map keys and stuff. When i go to the Device tab under setting it says that my device Status is "Malfunction". I've tried uninstalling and reinstalling the software about 20 times now and tried all 8 USB ports on my PC and still i'm having the same problems. Please help! Sort of disappointed that this is happening on my first Corsair product.

Link to comment
Share on other sites

Thanks for the quick reply! I've updated my System specs to the best of my knowledge..

It's an older computer but it still works fine running games such as DotA, Counter Strike and WoW. I mean the computer being old shouldn't be causing this problem right?


My Specs are :

MB: Gigabyte EP43-UD3L,

Ram: 4 Gb Ram (2x2) (can't remember which brand it was either kingston or corsair)

Windows 7 32 Bit

CPU: intel Quad Core Q8200 @ 2.33 GHz

GPU : Nvidia Gefore 9500 GT 1GB

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...