Jump to content
Corsair Community

K95 RGB Advanced Setting LED showing red even if black color selected


madmeatballs

Recommended Posts

Hi, so I recently bought a K95 RGB.

 

I am trying to customized the LED colors to what I want. For some reason on "advanced setting" in CUE if I select black it the LEDs turn red and the WASD, Arrow keys, and G-keys are somewhat cycling pink, red to white(G-keys stay in a light pink color and flickering, actually all keys are slightly flickering). Also, when I try to select a color it is always red+white, red+blue, red+green, and etc... How do I get rid of the red?

Link to comment
Share on other sites

2 possibilities here: either you have a red color setup on another layer but have not noticed it (CUE can be confusing initially) or you have a hardware issue.

 

To check the first issue try creating a new profile and see if the same happens there too. I would also suggest forcing a firmware update again using the latest version. In CUE under SETTINGS > DEVICES click on the Update Firmware button and choose the option "Force a firmware flash".

 

 

If the above doesn't work you might have an hardware issue and that requires to get the keyboard replaced. But we can worry about that later after you try the above steps.

Link to comment
Share on other sites

2 possibilities here: either you have a red color setup on another layer but have not noticed it (CUE can be confusing initially) or you have a hardware issue.

 

To check the first issue try creating a new profile and see if the same happens there too. I would also suggest forcing a firmware update again using the latest version. In CUE under SETTINGS > DEVICES click on the Update Firmware button and choose the option "Force a firmware flash".

 

 

If the above doesn't work you might have an hardware issue and that requires to get the keyboard replaced. But we can worry about that later after you try the above steps.

 

You were right I was really confused with CUE. I was actually trying to figure out how to remove that layer.

 

It's working perfectly now when I created a new profile. But how do I remove/edit other layers?

Link to comment
Share on other sites

Depends on how you applied it really, did you apply a color to a group of keys? If so you need to re-select the same group and remove the color from it, if you tried to remove the color from each single key manually it wouldn't remove it.

 

 

For further questions you can post in this subforum made specifically for CUE questions: http://forum.corsair.com/v3/forumdisplay.php?f=267

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...