Jump to content
Corsair Community

Scimitar mouse... is not found


Recommended Posts

I received the Strafe keyboard and scimitar mouse for Christmas. The keyboard works great. The mouse was working, but now it is not. The CUE program doesn't know the mouse is there. It doesn't show at all in CUE, but the keyboard does.


Right now it functions as a normal usb mouse. No interesting lights (which I do not care about) and using the side buttons does nothing (which I DO care about).


This started when CUE started demanding updates a few weeks ago. I updated it, and it worked for a few days. Then it stopped, and said its time for another update. Then it stopped working, and said its time for another update. There may have been a firmware update in the middle there somewhere. At any rate, everything is up to date.


Now... it does not state it needs an update. However, CUE does not know the mouse is there. OK, to try to fix that I have:

Relocated the mouse to other usb spots. Restarted the computer.

Repaired CUE. Restart.

Deleted Cue. Restart. Reinstalled cue.

Did all the above after removing and relocating mouse. Nope.. still now working.


Some of the other posters mentioned logs. I've no idea where they'd be.

Link to comment
Share on other sites

Well, it's working now.


I tried uninstalling CUE, and reinstalled the old version. There's a button inside CUE to update it. I used that, and now it works.


Previously i was using the notification in the kickbar to update.


Other than that... this wasn't different from any time previously.




I noticed TeraByte responded in the meantime. Thank you for at least listening

Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...