Jump to content
Corsair Community

Unable to install CUE


Recommended Posts

I just did a clean install of Win10 Home x64 and the first thing I did when it was complete was try to install CUE (no other third party programs installed yet). When it gets to the point where it's installing driver 1/2 it hangs and I have to hard reboot my PC. I tried several times to install CUE and got the same result every time, even after a clean reboot.


So I came here and read a few threads and have tried all of things suggested including installing to a different drive, plugging my keyboard into USB2 and trying older drivers back to 1.12.75 all to no avail.

Link to comment
Share on other sites

Yeah, I did that to no avail... and I've had to make command decision (retired Navy :P). My PC's primary mission by a long shot is gaming, I stay in touch with the world on my Android, so without its peripherals it's pretty much a brick and I am as we speak reinstalling Win7.


The last attempt I made at installing CUE into Win10 generated a text file called msi.log that seems to my untrained eye to describe what happened- is there a better trained eye I can send that to?


FWIW, I also couldn't install Logitech Gaming Software- same symptom, it would get to a certain point and freeze my PC, so I suspect this ain't a Corsair or a Logitech problem. I noticed the OP of another thread who was experiencing the same exact thing as me has the same MOBO I have (Asrock Z77 Extreme) which means he also has the same onboard audio and someone in that thread implicated audio may be involved- makes me wonder if Win10 doesn't like that particular audio chip.

Link to comment
Share on other sites

Im having the same issue here too, as I recently bought a Sabre optical RGB mouse and cant get the software installed.


The following may help??

So I had a small issue installing the drivers for my V1500 headset a few weeks back. after I got things running OK ( takes 30 seconds to load into the headset software, PC takes AGES to boot up / down when I have the headset plugged in).

When i started reading around I noticed audio seems to be the first driver that CUE installs so it got me thinking. However, when I went to deinstall the V1500 drivers / headset software, SAME thing - everything would just freeze, causing me to hard reboot.

Ive managed to delete the actual files, but I can not uninstall the Corsair Software through windows control panel - it appears to have worked but its still there, and I can try again and the same thing.


I tried installing to a different drive but no dice....


I have a feeling its something to do with the V1500 messing around with the new CUE software.



Im off out for the morning but will respond when back if ANY kind individual could assist it would be FANTASTIC



Link to comment
Share on other sites

We have a weiner.....


So after reading what I posted I did what I would have suggested to someone else in my shoes.... (derp derp moment, didnt see the "show more restore points" check box and thought I couldn't...




After rolling back with system restore to when I installed the headset drivers, and trying to run CUE installer again it sailed through without an issue(touch wood) ((hehehe, wood))


It appears that the issue was indeed the driver / software for the V1500 headset.

I was hoping that wasn't the case as I have a few mice but only 1 surround headset, but I am super stoked its sorted for now.


If this changes I will be CERTAIN to post here again in the hope that it helps prevent at least ONE other person from going through that 'barrel o laughs'

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...