Jump to content
Corsair Community

Making scroll lock stop blinking in BIOS mode?


Recommended Posts



I have been a Das Keyboard and Ducky user for many years, but I wanted to try something new and bought a K70, which I have been quite impressed with so far.

However, during early boot, many keypresses are being registered two or three times, thus making me unable to enter my encryption password. If I switch to mode 1 it works, but the scroll lock LED keeps blinking, which is very annoying.

So far I have been switching to mode 1 during boot and then to one of the other modes after booting, but this is very annoying. Especially since the keyboard often stops working after switching modes (I'd say in one out of four cases), requiring me to re-plug the USB connector in the back of my computer, which is even more annoying...


As far as I understand, mode 1 is some sort of compatibility mode for old BIOSes. My motherboard is an MSI Z97A Gaming 7 running in pure UEFI mode, so I wouldn't exactly call it old.

My previous keyboards worked just fine, so apparently they must have been running in old BIOS mode all the time, yet everything worked as it should, including full N-key rollover in both Windows and Linux. Why is compatibility mode such a bad thing according to this keyboard?

Can I disable the scroll lock blinking somehow, so that I can use mode 1 normally?

Link to comment
Share on other sites

Yes, what you are using is infact called BIOS MODE. Using it disables all advanced features on the keyboard (like anti-ghosting, macros, etc) and the scroll lock light blinks to remind you you are using the "legacy" mode.


As far as I know there is NO way to disable the blinking. Unless Corsair has some kind of hidden keys combination for it, but so far nobody mentioned it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...