Jump to content
Corsair Community

Strafe RGB auto run macro?


Recommended Posts

Hi i have been trying to make a macro to auto run in Dayz but its not working, or i get it working but it will not stop, even when i shut down dayz, and i can't turn it off.


to run fast in game i have to press Rshift plus uparrow keys.


so i added a macro to ' key with the above key presses, to toggle it on or off.


what have i done wrong? thanks

Link to comment
Share on other sites

Untick Disable Ctrl+Break listening by right clicking the CUE icon in the notifications tray. To stop the macro, if pressing the key again does not work, press Ctrl+Break to stop it.


It could possibly be a CUE related issue rather than something else causing it.

Do you have the latest Windows, drivers, etc installed?

Have you tried reinstalling/Repairing CUE?

Link to comment
Share on other sites

I also have that issue, toggle on/off doesnt work for held down keys.I tried every possible way to make that macro, and it wouldnt work correctly.Your old software does it fine


Heres a screenshot of my macro, in the old and new software.Old works new doesnt.



Edit:attachments dont appear to be showing

Link to comment
Share on other sites

  • 2 weeks later...

It is really easy to reproduce. The macro is just 2 actions. Hit Record and then press and hold Shift (Sprint) and W (Move Forward). Now without releasing Shift or W, press the stop button. The Macro simply activates the set keys but doesn't release them, making it as if you are holding those keys down in game. The problem comes when you want to stop. In previous versions (and the correct way to handle this is), all you had to do was tap the [W] and [shift] keys ingame, and everything went back to normal. The Macro doesn't need to repeat or stay active or anything like that, just simply pass the key down event without ever passing the key up event. To stop the effect, all you had to do was manually pass the key up event by manually tapping the actual key being emulated.


The Macro used to work perfectly in previous versions of the software. Some change was made, and now this really simple (but awesome) feature is ruined for the time being.



It appears that this *might* be a Windows 10 issue. I made the same macro in Logitech Gaming Software and it handles it the same way. I think it is unlikely that both CUE and Logitech's software were both updated to handle this macro incorrectly.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...